VSTi Sequencer Midi Out Channel Setting Ignored

Hi folks. I am trying to use VSTi’s like HY-RPE2 or RhyGenerator where both basically generates euclidean rhythm sequences. They aren’t instruments, they just play notes where its Midi Out should be set as Midi In in the VSTi’s that I want to be played by them.

What I am having is that, both sequencer VSTi’s (HY-RPE2 and RhyGenerator) has the capability of having multiple channels with different sequences (therefore multiple Midi Out Channels with that would play each different sequence per channel), where with 1 instance of them I could play multiple other VSTi’s in the same time but with a different sequence in each VSTi (because each of them would be receiving a sequence of a specific midi channel), but I do not know what am I doing wrong, that with both sequencer VSTi’s, if I set multiple sequences being sent in different Midi Channel outs, and then I set multiple VSTI’s having them with Midi Inputs pointing to them, specifying different channels, the channels are being ignored. Looks like no matter which channel I set, they play all the sequences of all channels (like if I had a sort of a Midi Omni option set) instead of respecting the sequences per channels.

Sorry if I didn’t describe in a way that is understandable, but is a bit tricky to describe by words. Any clue on what I am doing wrong?


Cubase is always receiving at all MIDI Channels. Use the Input Transformer to filter the MIDI Channel, please (the presets are available in Cubase).

1 Like

Thank you @Martin.Jirsak ! That is it!