vsts not opening 'on top'

when i go into edit channel setting and hit ‘e’ in the insert strip the plug in used to pop up on what ever screen i was on, its stopped doing that and is behind all the windows, so i have to minimise stuff to get to it - ive gone into preferences - plug ins - slected always on top and it still doing it - am i missing something?


If you right-click to the header of the plug-in window, is the “Always on Top” enabled?