W11.2 Licensing problem

I installed the latest version of Wavelab thinking (stupid of me) that transferring the licence from the old to the new licencing system would be easy. Ha ha…
I have been doing this kind of stuff for twenty five years, so I usually don’t query hotline all that much, but this time, I don’t get it : my wavelab is now in demo mode and will expire in a few days and I need it.
Please, what is the path to follow to go from the old system to the new. Or do I have to reinstall some version ? Which one then ?
Thanks for any light on the subject
Footnote : I don’t mind licencing stuff *as long * as it is made user friendly…

What are the steps you have taken so far?

What exactly is displayed in the Steinberg Activation Manager?

For the new licensing system you need Wavelab 11.2 and then you need to enable the license via the Activation Manager, that is automatically installed together with the Download Assistant.

It would clearly help if you first do what @Scab_Pickens has asked, what steps have you done so far and what release on what OS are we talking about.

I will do that in a while (not in my studio right now), but the weird thing is that there is no path explained to transition from one to the other. All the readme etc are a little vague

My impression is that you only get to use the new licencing system when you actually buy Wavelab presently.
I’ve owned wavelab and upgrading for twenty odd years !.
I tried reinstalling the previous version but obviously the new licencing system stayed.
The new manager app does not see any licenses. That’s for sure.
Presently I use an Intel Late 2013 Mac Pro with Mac OS Monterey

Try here…


regards S-EH


When you say you installed the latest WL version … 11.2 … how did you do that?

If it was through Download Assistant, then after you first time log in, your licensed product would be available for download … that is download from the Download Assistant … and should just install.

Like others. I had some issues post-install but these all seem to have been resolved over time.

Good luck!

No license found after updating to WaveLab 11.2 / WaveLab Cast 1.3 – Steinberg Support

Thanks everyone,
Problem solved, thanks to the support guys, the procedure is a bit tricky, but straightforward, as long as you get to know what to do !
In my cas things where aggravated by the fact that I had some confusion in my accounts. It absolutely need you to have that elicencer licence proprely referenced in your steinberg account.
I will probably close this forum account because it has been created with a old mail address and this has further confused the issue !
Thanks again

1 Like