Waldorf Filter jumping values BUG

Discovered another bug today. The Waldorf Filter type jumps values, making it unsuitable to be attached to some bitmaps. The error can be sceen with elements such as animations, sliders and knobs. It seems to be related with the bug that I reported here before that was patched. Here’s how to create the bug (Using Windows 10 64bit)…

  1. Launch Halion 6.
  2. Hexagon loads… Right-click the program (Hexagon) in the slot rack and click Init Program.
  3. Click the ‘Open New Window’ button and select ‘Macro Page Designer Extended’.
  4. Click the ‘Create A New MacroPage/Library’ button and Select create a ‘Halion Sonic Macro Page’.
  5. Navigate in the bottom browser panel for any slider template (Basic Controls>“Slider V” is a good one to see the bug)and drag it into the visible macro page area.
  6. On the right side, navigate the program tree to and left-click the Synth Zone.
  7. Navigate in the SOUND panel to the filter section and set filter type to “Waldorf”.
  8. Next, while still in the SOUND panel, right-Click the filter shape drop down box and select to connect it to the macro page.
  9. Right Click the slider template placed in the macro page (back on step 5) and connect the Synth.Zone.Filter.ShapeA paremeter to the slider.
  10. Next using either your mouse scroll wheel or left clicking, go through each filter shape option.

At this point you will notice the slider will jump huge increment values when moving from some filter types to the next. It’s the most noticeable when going from BR24 to LP36. What seems to be the case is that the Waldorf Filter type has essentially the same table of filter shapes as the other filter types but it is instead filtering out the other options in order to present the associated shapes. The issue is that it’s jumping huge values making it impossible to attach the parameter to some elements. The Waldorf filter does not self oscillate at audible values so I’m not sure how this can be fixed. Just showing that the bug does indeed exist.

I don’t know if this will be fixed but I just want to mention that I found somewhat of a work around at least when tying this parameter to an animation. If you create an animation with 30 frames you can then render blank frames in specific spots to account for the skipping around that’s going on here. Basically there are 30 filter shapes so if you create blank frames to account for the filter shapes that are not available for the waldorf type then you can sync the movement of the parameter with an animation properly.