Warning: there is no tech support

Earlier I was having problems installing Dorico from the download assistant, so I filed a request to tech support. Unfortunately the tech staff are not making any effort whatsoever. Just look at this conversation:

Subject: Download missing
Description: Hi, I installed the Dorico download assistant and entered my activation code in eLicenser successfully. But the download assistant sits there with a blank table of downloads and does nothing. I tried restarting the assistant after activating my license in the attached eLicenser dongle, but it still does not figure out that I have a download available. Is your system overloaded now? Please let me know when I can download the product. Thanks.


Hello Byron,

Thank you for contacting the Steinberg US Support team. My name is Chris and I will be assisting you with your request. I’m sorry for the trouble. I would suggest using the Steinberg Download Assistant from > http://www.steinberg.net/en/support/downloads/dorico.html

I believe this should resolve your request, so you may receive a survey. That said, if you are still having the same issue, you can reply to this email and I will be happy to help further. Thank you.

Chris Dobbs
Steinberg US Support

Really? He thinks I should use the download assistant instead of the download assistant? Users beware: as of today, there is no tech support for this product. Fortunately Daniel solved my problem before this other guy sent his robotic reply.

Something sounds weird.

I didn’t enter my activate code until after everything had downloaded and installed.


I sympathize, but in fairness 1.0 Release Day is hardly the one to use as a basis for judging Dorico’s technical support. Hopefully once things settle down just a bit things will get better.

It’s great that Daniel jumped in and helped you. I can’t imagine when he got even a half hour’s sleep.

Hello Byron,

I do apologize for my error. This was the first case I’d had with the issue and I misread your email and believed you were having a download problem from AskNet. I have emailed you the direct link, and again, I am sorry for my mistake.

That apology was a very nice thing to do so publicly, Chris. Thank you.