Good morning all,

I’m a newcomer to Cubase and a friend and I are trying to utilise VST Connect Pro.

However, any time I load up Connect Pro I get the attached message.

Can anyone help please?
VST Connect.PNG

(the clue is in the error message !)

what version of cubase ? how are you adding VST connect pro ?

if you use a blank project and use the VST Cloud menu >> create VST connect all the plugins should go into the correct places.

FWIW - “PRO” needs a paid licence - “SE” comes free with cubase. If you are just experimenting the SE is fine to start out with

He’s using Cubase Pro and VST Pro. We have both been working on this problem and have set up identical setups but he is getting the warning message an I am not. We both have the same versions of software.
We both went through the exact set up of a project.

Empty project

Set up inputs out puts and control room

Started VST Connect fron The VST Cloud menu/VST Connect Pro/Create VST Connect

He gets the message and I don’t.

Re-installation of Connect didn’t work.

It all seems to work once the message is canceled but it’s still worrying.

“Set up inputs out puts and control room” - probably there is some mistake in that section.
Empty project, don’t do anything but VST Cloud/VST Connect/Create VST Connect, that’s it. Don’t insert anything anywhere yourself unless you know exactly what you’re doing.
The message very clearly states that the VST Connect plugin has been inserted somewhere other than an Input Channel. Don’t.

Hi Jim

Why the second action? In other words: why set up the channels? VST Connect does that for you.

Hope this helps.

Just set up input channels for recording in the Studio side. We did do a set up just by setting up VST connect on it’s own without without any other channels being set up but same warning turns up.


where is the VST connect PRO plugin inserted on the non-working system ? can you take some screenshots and post them here ?

I’m more than willing to bet that soundmanduncan has inserted it on an audio track NOT an input channel - it will probably still recording something but that’s not how it set up

In summary - at the studio end - there are 3 plugins. 2 of them in the “control room” and the 3rd (vst connect pro) MUST go in an input channel (press f4 and look at the inputs) NOT an audio track.

Just to give anyone an update I’ve added screen grabs of how I’ve set the project up and attached them.

You have set the project up?
IF answer = no
THEN stop reading
ELSE read on

Make it your mantra:”Do NOT set up VST Connect by yourself. Let the program do it for you.”

No disrespect meant. Just trying to help as I remember too well how long it took me to learn the ropes.

thanks - BUT where is the VST connect PRO plugin inserted, hopefully NOT in the Performer Rec channel.

It needs to be in the INPUT channel (called VST connect)

the clue really is in the error message !

That is all ok. The question is if you inserted the plug in the Performer Track? Or anywhere else, so open the inserts lane in the mixer to check.

Half an hour ago I went through a step by step set up with Dunc. We both did exacly the same steps.

Opened an empty project

Audio connection: Deleted all inputs. Only Stereo out in outputs (Not connected). Control Room switched on: Only Monitors set to output 1 and 2. Group/FX and External FX Empty.

Start VST Connect Pro: Get option to select Talk back track. Selected talk back track.

Error message for Duncan and not for me.


where is the VST connect PRO plugin inserted on Dunc’s PC…?

(please read the many replies !)

I’ve read the replies and I know that everything is in the correct place.
Duncan did a reinstall of Cubase and the problem has fixed itself.

Thanks for any help.

good news - let us know how you get on :slight_smile:

super weird though. But thanks for great help!

That problem seems to be solved but got a bunch more. Not got time to list them but one is when you deselect always on top in VST connect the VST Connect screen it just turns black. If I open it up it’s all back again. Selecting Always on top does’t return the screen to normal.

are you using multiple monitors ? if so then just move to the primary

dr Thanks. It was because I had moved it to my second monitor. The controls all come back if you move the window to the first monitor and select Always on top again.

Now for the madness.

We went through the same process as before and we did this from both sides just to check. Empty Project/Got rid of all audio connections apart from a stereo out in the control room/Added VST Connect. (set up fine with no error)

This from my side as the Studio but we had aturnaround Dunc did the same.

I added a Groove agent track.

Duncan as performer added a Guitar rig into Insert 2. Groove agent doesn’t show up in the inserts on my end (studio). When I hit play the drums are being fed through Groove Agent.

My first thought was that groove agent was being fed through another channel somewhere but since we set this up as explained above That didn’t seem likely.

Next I got Duncan to remove groove agents from the inserts and added Groove Agent from my side instead. Work as expected. As said previously we then, after a lot of head scratching, did the same now as Duncan as the studio and got exactly yhe same results.

Du you intend to use GA as an Instrument for the Performer? Use the Instr. item on the top left of the Performer interface, not as an insert. What channel did you insert it?