Waveform disappears when Zooming out

So… If I’m zoomed in on a spot I see the waveform just fine. But once I start to zoom out… It’s completely gone. There’s no way to edit like this. I’ve looked through the Preference-Event Display tab… I’ve looked everywhere. Any help would be greatly appreciated!!!
I’m using Cubase 9.5…

So I spent some time in a chat and found out my issue. So hopefully this helps someone else else…
Yes, the ‘show waveforms’ box was checked (preferences) so the next thing we did was close out of Cubase and I opened the Windows File Explorer and went to the folder where my projects were being saved. There was a folder labeled ‘Images’ (apparently they can get corrupt occasionally). I deleted this file. I then reopened Cubase and my current project and the waveforms were all there. Between the operating system and the program itself, it recreated the ‘Image’ file with where is in there and its working great! Good luck.

Check quick zoom is disabled in preferences under edit menu. Tada

Check quick zoom is disabled in preferences under edit menu. Tada