Wavelab 10.0.40 - LAME Mp3 encoder time bug (doubles time of song)

Hi just come across a weird issue with using the batch processor to convert wavs to MP3 and seems to only affect if using LAME, the Fraunhofer one seems to work as expected

when converting to LAME (options i chose were match input rates, and VBR HIGH, with highest quality)
run conversion and all seems fine

until you try to open the output files in anything like foobar/media player/vlc etc
my 3 minute song has become 7minutes 22

if i open the MP3 in wavelab, it shows fine as 3 minutes, but any other player sees the time as wrong (more than double the actual time of the song)

to reproduce…
Batch process WAV to MP3 (using LAME / VBR Highest)

to workaround - use the fraunhofer codec, that works as expected.

also when playing one of these broken mp3’s in foorbar (they should of been VBR) and i can see the values of the bitrate changing, however they are tagged showing as CBR and the bit where id expect to see the encoder - “encoded with” is blank

As another test in wavelab i chose LAME CBR 320K to encode with, and the timing of the song is correct (3mins), so the specific issue looks to be with wavelabs implementation of LAME & VBR?

(and i guess a feature request of please add the title of the encoder into the files)


with WaveLab 10.0.40 and OSX 10.14.6 Mojave

Check Lame encoder/decoder versions on PC or Mac
I have tried here with 3 minute sine wav
render to Lame VBR high resolution
tested on Audacity, Quick Time Player, VLC of course with WL
and they all show 3 minutes in length!

regards S-EH

Hi, so maybe windows only issue… sorry i forgot to add im on Windows 10 x64 build 2004

I see a few seconds of difference here, but this is because the LAME version does not create extra info about the mp3 file, hence the length if guessed by the player.
If the length is important for you, use LAME + CBR or Fraunhoffer any mode.

I get exactly the same thing when the file is opened in Foobar or a VLC playlist. A 3 minute music track becomes about 6 minutes.

But it’s close to the original when opened in iTunes playlist or VLC normal open.

I would just use LAME cbr until or unless a vbr xing header is added for the lame. Or maybe the LAME vbr option should just be removed.

afaik LAME (within that other package I can’t remember the name of) is still used by Amazon and they’ve switched to VBR after being CBR for a long time, so if you wanted to get really picky and exact about what it’s going to be like on one of the biggest places selling mp3, the lame vbr function should be made to work as expected in Wavelab if possible in my opinion.

Well yes the length is pretty important, i don’t use MP3 so much unless need a small sized file to share with a friend… and usually use foobar lame vbr v0, never had issues with times as I’m guessing foobar has the correct implementation.

I just thought I’d test wavelabs conversion to save me an extra step.
I suggest that if lame vbr isn’t to be fixed it should be removed as an option