WaveLab 10.0.60 Unfeasible To Use It Due to Crashes

I am not being able to use WaveLab. It always crashes while I am using it.

I am working on a Macbook Pro 2017, i7 Processor, 16GB of RAM, 512GB SSD, and I am running it in Mac OS X Catalina 10.15.7.

What should I check in order to see what is crashing the software?

Following a small part of the error report (tried to put it entirely but it is too big and the forum does not allow it):

Process:               WaveLab Pro 10.0 [5490]
Path:                  /Applications/WaveLab Pro 10.0.app/Contents/MacOS/WaveLab Pro 10.0
Identifier:            net.steinberg.WaveLab-Pro-10-0
Version:               10.0.60.174 (10.0.60.174)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           WaveLab Pro 10.0 [5490]
User ID:               501

Date/Time:             2021-03-18 14:30:11.235 +0100
OS Version:            Mac OS X 10.15.7 (19H524)
Report Version:        12
Bridge OS Version:     3.0 (14Y908)
Anonymous UUID:        1B9F6707-946B-AB70-7702-89234FBF064C


Time Awake Since Boot: 350000 seconds

System Integrity Protection: disabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x00006000928f3db2
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [5490]

If you zip up the crash report, the forum will allow it as an attachment…or you can link to the full crash report on Dropbox etc.

Hi!

Step by step repro will help PG

"I am not being able to use WaveLab. It always crashes while I am using it.

this will not help

regards S-EH

Hi folks! Thanks for the reply!

There is no way for me to have a step by step. That is the worst because it is completely intermittent. This last time I was, for instance, clicking in the upper File Manager tab to open a new audio in the existing workspace and then it closed right away with no error messages, only the Mac OS error with the log.

I had 3 FabFilter plugins in my master bus when this last crash happened (FabFilter’s C2, Q2 and L2), and nothing was being played. But no matter what I have in the master bus,
the error happens randomly. I mean, I cannot use the software with such instability unfortunately. Maybe is related with the VSTs that I load in the master bus but, like, I dont have a specific set of plugins that I put there, I always experiment new things. Maybe I can try to not load any 3rd party plugin there and see if the issue remains?

I am attaching the complete log file in this post.Debug WaveLab Error.zip (30.8 KB)

The attached crash happens during decoding an AAC file. I guess this AAC file has something special that the Fraunhofer decoder does not like. Where this file come from?

I had a Cubase generated MP3 file open with FabFilter’s VST3 plugins loaded in the master bus.

I am playing a bit using only native Steinberg plugins in the master bus. Looks stable so far.

I don’t think this file has the .mp3 extension. It was not recognized as mp3 by WaveLab.

1 Like

Hum. Weird. But, anyways, I did some research and I realised that WaveLab is very sensitive to 3rd party plugins. I’ve been testing using only the Steinberg plugins and it not crashed at all. Also I checked and realised that FabFilter plugins has a set of dynamic plugins (the ones that I use most for mastering) that has the “Mastering” word as prefix, like “Mastering: FabFilter Pro-C2”, “Mastering: FabFilter Pro-Q2”, so on and so fourth. I am using them now during some time for testing (they are VST2 by the way), no problem so far.

I think that, indeed, my issue was that I have been setting any plugin without worrying with its compatibility with WaveLab.

By despite all of that, I think that the WaveLab team should implement some way to handle such kind of errors to not allow the software crash in that way, at least giving a message with an idea of what can be that is triggering these errors. Me as user, get completely lost having a crash like that just closing the entire window and not giving a hint of what can it be.

FWIW, I use FabFilter VST3 in WaveLab daily without crashes. DMG, Plugin Alliance, Goodhertz, Soothe2, Sonnox, Tokyo Dawn, Toneprojects Unisum, and most iZotope plugins are also solid here daily. I actually don’t use any Steinberg plugins :slight_smile:

1 Like

@Justin_P thanks for the reply! I am aware that there are people that indeed may face crashes and some not. I am just repeating what I read in a thread in another forum with a similar issue that a user raised. What I can see is that this kind of issue does not occur to everybody, and with every plugin. Unfortunately I am having a bad luck. Now, using only VST2 fabfilters that is showing with “Mastering” prefix for me, is working fine.

There are also another issue related with the encoded audio that I was using verified by @PG1, which checked my attached error log, so, as you see, I am having different variables that may crash the software.

I am learning the tool so I posted here because I got lost. Now I am understanding at least what can trigger the errors that I have been facing so far.

In order to not leave this thread open with a sort of a “non solved” status, I will set this post as the solved with the following conclusions:

  • There will be users that may face issues and others don’t
  • For those that have this crash issues, try to check the following:
    → Confirm if the encoded audio file that you are playing is not damaged somehow
    → Verify your 3rd Party VST plugins in order to see if WaveLab is compatible with all of them because it is sensitive to 3rd parties plugin (as far as I read in other threads around internet), try to change from VST3 to VST2 or vice-versa to see if the issue remains

That is it. I did some tests and now I realised that with Mastering FabFilter plugins and Steinberg plugins, the software is stable. Also, there is the fact that maybe the audio that I loaded that triggered the crash that I specified in this thread was also damaged/invalid.