WaveLab 11.0.10 Crashes using NUGEN Audio plug-ins

Greetings to all. I upgraded to WaveLab Pro 11 from Pro 10 and, for some reason, the app crashes as soon as I instantiate a NUGEN Audio plug-in in the master section. I did all of the following: (a) rescan my plug-ins, (b) reset the master section, (c) try with a brand-new montage file. Note that the plug-ins work fine on my WaveLab 10 installation.

Any clues on what may be causing this?

1 Like

FWIW, a few years ago I spent a lot of time and sent many emails and crash reports to NUGEN because their plugins were indeed causing Wavelab to crash. Probably around WaveLab 8.5 or 9.5. Before 10 for sure.

At first NUGEN seemed to take it seriously but ultimately, their interest in getting their plugins to work well in WaveLab seemed to dissipate and rather than deal with the crashes and bugs, I simply stopped using NUGEN plugins.

If I were you, and still wanted to use NUGEN plugins in WaveLab 11, I would locate the crash reports on your system and send them to NUGEN with as much info as you can. It also wouldn’t hurt to post the crash reports here for PG to analyze but 9.9 out of 10 times, a fix like this has to come from the plugin developer.

Thank you, this is helpful!

I had the same experience… What a mess.

I had a similar experience with IK Multimedia. At one point I used the Stealth Limiter a lot. I loved that plugin. But it did not play nicely with Wavelab. Definitely no fault of Wavelab. It was the plugin developer that just got sloppy and didnt care about their end users.

I’ve just emailed Nugen complaining about it.
It’s insane. It crashes instantly.

Maybe, Steinberg/Yamaha could put pressure on them too!??


I believe they tried back in 2015. See my attachment from Ed at Steinberg.

NUGEN just doesn’t seem interested in or have the resources to look into this.

Well - before everyone comes down too hard on Nugen - please remember that Wavelab (and ONLY Wavelab) has had a very shaky history with a sorts of plugins from all sorts of plugin vendors over the years. (Wish I could pull in 50 or 100 posts from the old forums right about now).

So when I see a post like this - and folks trying to actually defend WaveLab - it should be taken with a grain of salt. WL is not even close to being perfect in the plugin department - especially when Nugen works just fine with other vendor DAWS. Do not have even the slightest sign of trouble using any Nugen product in Studio One for example.

If Nugen was really that bad - it would be crashing everywhere…


It’s certainly a two-way street but NUGEN doesn’t seem interested in participating so I moved on. Plenty of other great plugins out there that work very well in WaveLab.

I don’t think WaveLab is the only DAW to have 3rd party plugin issues. I hear about similar cases in Sequoia and Studio One…two lesser used DAWs compared to Pro Tools, Logic, Cubase, etc. Especially Sequoia.

1 Like

Well we do not have threads like this on the Studio One forums…

Official 3rd Party Plugin Issue Thread - WaveLab - Steinberg Forums

You know when you get your own dedicated thread about plugs that do not work in your product - that there might just be a major problem somewhere.

Or this…

WaveLab 11 GUI Lag with Certain Plugins - WaveLab - Steinberg Forums

Or this…

Maat thEQ Orange - preset loading weird problem in Wavelab 11 Pro Montage - WaveLab - Steinberg Forums

Especially Tom’s comment within the fourth entry…spot on.


1 Like

Never had problems with Nugen audio plugins in Cubase or Wavelab.

Here my plugins from nugen Audio (all of them running fine in Wavelab elements 11.0.30, Cubase pro 11.0.41 and Cubase Pro 12

Visualizer 2 (
Monofilter 4 (
Aligner (
Stereoizer elements (

Me either. I have Mastercheck, ISL2 and Audio Aligner working perfectly here in both Wavelab (10.x) and Studio One (5.5.x)

I sometimes wonder if there is something more sinister in play on an individuals workstation rather than always blaming either the Host or the VST plugin.

There are an infinite set of computer combos out there and not all of them are stable.



I tried to install and use MONGOOSE from BOZ and it crashed WL everytime I tried to open it. There are some plugins that simply do not like WL for whatever reason but work in other DAWs. This has been going on for YEARS. It is funny since Steinberg was instrumental in developing VST technology. FWIW


Mac or PC ?

I downloaded Mac demo version MONGOOSE from BOZ version 2_2.0.2
and it works fine here with OS X Big Sur and WL 11.0.30, no crash…

regards S-EH

These ones work too… ISL st doesn’t.
There’s one more that also bugs often, but I have to check it again… it’s not as important as the limiter to me.
Nugen is aware of it.

The problem is happening in WL 11 Pro 11.0.3. WL is OK Iguess.

Windows 10 pro.

Nugen has updated ISL. The Limiter is working now in Wavelab 11.0.30 here! :slight_smile:

I’m using the Nugen ISL2 version and now it doesn’t crash Wavelab!


1 Like

Nugen Mastercheck (V 1.7 last version) still crashes Wavelab Pro 11.1 here

Mac OS


I was on test wavelab with trial eLicencer Key, i try to upgrade and buy, but elicencer trial Key Don’t Deleted it’s always on Pc, i already try to deleted the elicencer and wavelab from PC, And install again, but the same trial Key it’s there!
I don’t know what to do to upgrade, buy wavelab and put a Buy eLicencer Key !

Any one can help me ?

Thank You Very much

Nell Silva

Unsurprising. I tried rather hard to get NUGEN to look at all my WaveLab crash reports related to their plugins and they did not seem interested in trying to solve the issue.

I like their plugins but I had to omit them from my workflow in WaveLab and haven’t looked back since. or even felt the urge to re-test them to see if they got better which is sounds like for the most part, they have not.

The fix lies with NUGEN.

1 Like