WaveLab 11.0.10 Maintenance Update

Dear Forum members,

We have just released the first maintenance update for WaveLab Pro and Elements 11, version 11.0.10

This update resolves many critical issues across different areas of the applications. We strongly recommend installing this update to ensure that everything runs smoothly.

As always this update is available for download from the Steinberg website and via the Steinberg Download Assistant .

For detailed information, please refer to the corresponding version history.

All the best,

2 Likes

I can’t install this update, error code 1603. Any ideas? (Win 10)

P-5251 Using the “Save As” function now adds the file extension automatically.
Thank you!

Much better version - you should start 11th edition with it instead of build 24 :wink:

Using macOS 11.6 (Big Sur).
Download Assistant returns an error message when being started pointing me to contact support. When clicking away this message opens the window where I can see the update but, again, can’t download it. Reinstalled Download Assistant from the webpage - same result.
Installed update from the webpage.
Wavelab 11 still not being listed in the “My products” drop down menu, only 10 from which I upgraded.
sigh
Update:
even after explicitely allowing Download Manager in LittleSnitch outgoing connections (which wasn’t required before) it can’t connect to the Download Manager.
Is the Download Manager website down?

2nd Update: Suddenly Download Assistant worked again.

Hi!

Download Manager works here but is very sluggish app
and I don’t have a bad connection with the net…
so keep trying

regards S-EH

1 Like

Updated from within Wavelab 11. All showed successful and restarted pc. Wavelab 11 program start not now on screen and can’t find it. This PC>OS(C:)>Users>name>Steinberg>WIN64>WaveLab Elements 11 folder exists from previously downloaded version with installer program.

Try erasing the WaveLab Element preferences.

Wavelab Elements 11.0 was buggy. Couldn’t save a wave file as an mp3 because the program mistakenly thought that file already existed. Something I always have done in every version of Wavelab. Updated to 11.0.10 and more bugs, but that bug seems to have been addressed. Now Wavelab freezes, doesn’t start, etc. It took me four times to get it to open. Not happy with this version so far. Maybe the Pro version works better?

YES!

regards S-EH

Wavelab was not listed at all:(
In the end I loaded up the Steinberg Download App, downloaded Wavelab V11.0.20 and re-installed it. Seems Ok now…
There is no WaveLab Elements Pro as far as I am aware.
Thanks everyone.

At least on Windows, in case of problem, I always just re-install. For example, I have WL11 already installed alongside WL10 but I’m ready to uninstall WL10, so after that, I’ll just run the WL11 installer again – seems to solve a lot of problems.

Just a quick note that I managed to get this working eventually. It turned out to be a problem with Windows (that I never encountered before). I couldn’t repair or uninstall or anything, so I was really stuck. But after some fiddling I got it working.

WaveLab Elements 11.0.10 is the worst, absolute worst, release Steinberg has put out since Cubase 10.5. That was really bad, but this is worse. At least Cubase 10.5 would open. Since the 11.0.10 update I cannot use this program successfully. It had a few bugs in 11.0 but now it doesn’t open. After three attempts it opens, but then trying to “save as” crashes it. Matter of fact, doing most anything crashes it. Ugh, this is really not ready. Perhaps the Pro version is better, but this one? Nope, nada. no way, uh uh.

I am wondering what configuration you have because this is a very successful update. Trash all your preferences, at least.

It is not successful for me. 11.0.0 ‘sort of worked’, but once I updated nothing worked. I can use Wavelab Pro 9.5 successfully. I was using Wavelab Elements 10 successfully. But 11? Nope. I do not believe it’s my preferences, I believe it’s the program. Trashing my preferences never made Cubase 10.5 work successfully. Moving to Cubase 11 solved that. With no “preferences trashing” required.

WaveLab is a totally different application. If you trash all the WaveLab preferences, you will start on a clean context and should enjoy a positive experience as all others do.

Please listen to PG he know WL inside out
trash preferences for WL 11 and start over…

regards S-EH

Nope. Wrong. I actually do know what I’m talking about.
I did trash my preferences. And Wavelab 11.0.10 Elements worked a ‘little’ bit better. But it still freezes up when I’m trying to save a file. And it doesn’t always open successfully. Same as always since the 11.0.10 upgrade. At least the 11.0.0 version didn’t freeze when exporting wav files. It had the mp3 export bug.
Like I mentioned, I have used various versions of Wavelab successfully. 8, 9 and 10. I can recognize bugs in the program. Regardless of your condescending comment “…you should enjoy a positive experience as all others do”. I have worked at this for a loooong time, and am used to people telling me that the bug I found is something nobody else has found. Going back to 2005 using Logic when it kept freezing during. Burt Bacharach session when trying to record audio and midi. I got yelled at by multiple users on the beta site until Emagic said “yes, Ted is right” and fixed it. When Cubase 10.5 came out I was among the first to point out it wasn’t stable or reliable. CPU usage would jump. Nobody believed me until Steinberg admitted there was a huge memory leak in the program. And so on and so on.
So please stop telling me Wavelab Elements 11.0.10 is okay. It is not. Not by a long shot.