Wavelab 11.1 - AMD 5950x, Freeze in between every action

Been away for many years from doing any audio but upgraded my WL 7 license today, also a completely new AMD Ryzen 9 5950x and 128Gb matched ram 4x NVmE SSD drives so this computer is blazing fast…
Started WL 11 and tried to familiarize myself with it but each action i did froze Wavelab in between for several seconds and it feels more like a an old @ss 486 computer from the 80’s with completely defragmented mechanical drives… Is there something in this software that doesn’t like AMD? Is there an “intel setting” somewhere that expects Intel specific multithreaded action?

Brand new Komplete Audio interface and freshly installed drivers that works with everything else

This was a horribly disappointing first experience tbh

Would be fantastic if someone could point me in the right direction

Certainly not, as WaveLab is primarily developed on an AMD Ryzen Threadripper 3970X.

Restarted the App and it got slightly better but still freezes a lot, had 2 crashes out of no reason…

Checking the resource manager Cpu, memory, drives gpu is barely registering any activity, only ethernet that is momentarily has some activity… I’m deducing there’s still bugs that needs to be ironed out

Is there any debug menu that can be turned on to see WL 11.1 is fuzzing about?.. Seems like when i move between menus and predominantly “Files” and “Preferences” tabs back and forth… It completely freezes for some 10 - 15 seconds and yet another “Hmm let me think for half a day” with mousepointer turning into “blue circle” for yet another 15 - 20 seconds… I have a “theoretically” slow 5400 5TB backup drive (USB3) for 3D stuff and projects, still very fast to backup to and read from while into Zbrush e.t.c…

I will try and remove this to see if it’s actually scanning it fuzz about, but frankly, no other tools do this from the performance hungry apps i have… so constantly scanning the drives, in case it’s why it acts like a VisualBasic program, would be nice to exclude from being scanned… Or scanned with exclusion of already scanned files…

Wavelab 11.1 is currently making me really annoyed

Is your computer connected to Network drives? The WaveLab file browser might sometimes be slow when accessing remote drives. But not at all for all drives directed connected. Now, if your 5400 drive is sleeping (check your energy-saving settings), it will need maybe 10 or 20 seconds to wake up. That could be your problem.

Thanks. No. No network drives, also USB3 so it shouldn’t bottleneck anything, the USB drive should not be asleep at least not if Wavelablab already have woken it up… This freezing happens continously while already have been into the filebrowser, klicking on another tab, like preferences, then a few seconds later clicking the filebrowser tab…

If the 5TB USB3 drive were asleep it would probably take at least the normal 10 - 15 minutes before it goes into sleepmode again… However, when i back things up from Unreal, Zbrush, 3Dcoat e.t.c this drive never freezes albeit it takes some time to backup very large files…it reacts immediately so it should not be this issue… then those apps would show the same problem

I am running out of ideas, but there is something in your particular system causing this because WaveLab is conceived to be fast, and I don’t remember a similar report for WaveLab 11.
Try to disconnect some stuff, try to run a performance monitor,…

Is there a performace monitor in Wavelab? Or you meant in Windows… i wrote in my second message it’s barely recognizable any activity so that is no help at all…
No other tool i use has any of these issues… However i moved that 5TB drive to another USB 3 port and it’s sort of a recognizable difference ( to the better) but the “freeze” is still there an now occurs when inside the preferences and click the different tabs and functions…

Not sure why it has to “think” in between switching tabs… The 5400rpm drive was removed but the same “freeze” happens without it, attaching that drive and accessing it is fast, no hiccups.

I have tried some more things and i think i’m on a trail here… i have some OC tools that i disabled and it might be this causing the chaos… I will leave this open for abit if i can track it down.


In WaveLab, there is monitoring for the playback audio processing in the transport bar.
But I meant rather something external to WaveLab. Search for “windows performance analyzer”.

What brand of Audio Device and settings etc
maybe this has something to do with performance ?

regards S-EH

Yes i installed the Windows Performance Analyser SDK and will do a performance profile of my system.