Wavelab 11.1 update to new Licensing model does not work


I´ve installed the latest Wavelab update and tried to migrate my license as shown in the tutorial video, but it’s not really working. I do not really understand the problem. It is as follows:

The licenses seem to be on the USB Licenser. With this one plugged in, I can start both Cubase 12 and Wavelab 11.1

Cubase 12 already worked before, even without a dongle (well it still sucks that all Steinberg plugins like grand piano etc need the USB licenser, so it was not too useful for me…).

When I start the Steinberg Activation Manager, there is only Cubase 12 visible, no Wavelab 11.1

In my online account I see that Cubase is listed and activated, Wavelab is listed as well but it says “activated on no computer”…

After closing the activation manager again, both Cubase and Wavelab can’t be started anymore, they both crash during the starting , again and again…

Not sure what this is about. I can’t activate Wavelab in the activation Manager as it is not listed there, and I did it exactly as it was mentioned in the web tutorial where they showed how to do this with the voucher code. And it seems that these steps have worked, as I can see it in the license control, the licenses of Cubase and Wavelab both mention that they have been updated to the new Licensing system…

Anyone out there with similar problems or a solution for me?

Thank you!

Reboot, run Steinberg Download Assistant, let any auto-updates complete, reboot again.

Open Steinberg Activation Manager and click the double-headed refresh arrow. What do you see now in the Steinberg Activation Manager window?

Hi David, thanks for your quick reply. I did that, but unfortunately there is still only Cubase visible in the Steinberg Activation Manager—I clicked on the arrow and the circled points that indicate progress are rotating forever…no Wavelab visible…no Wavelab activated online as well, I’ve checked my account…it still says "Wavelab 11.1 not used on any computer…

Same exact problem here!

I’ve got the same problem now for over 3 weeks. Don’t see any solution eighter


Have you get in touch with Steinberg Support ?

regards S-EH

Please run the Steinberg Download Assistant. It will automatically update all licensing software. These are the latest version numbers as of today, which you can see by clicking the About button:

Wavelab 11.1 may not show up in the Steinberg Activation Manager if you do not have a recent version.

Please also make sure that you’ve claimed your free upgrade voucher.

1 Like

Thanks all.
prob is solved. I was running a wrong upgrade. Just installed the right one, passed all incl. license
and app runs great!

1 Like