WaveLab 11.2 Maintenance Update

Dear Forum members,

A new maintenance update for WaveLab Pro, Elements and LE - version 11.2 - is now available, supporting Steinberg Licensing only.

Besides introducing a few new features and resolving several critical issues across different areas of the application, the new WaveLab 11.2 update exclusively supports Steinberg Licensing, meaning the eLicenser will no longer work with WaveLab 11!

If you haven’t migrated your license to the new Steinberg Licensing system yet, this video shows how to do it: WaveLab License Migration | Support - YouTube

We strongly encourage you to migrate your license to Steinberg Licensing as soon as possible.

As always the updates are available for download from the Steinberg website and via the Steinberg Download Assistant .

For detailed information, please refer to the corresponding version history.

All the best,



Thanks for the update but it appears that Steinberg has NOT addressed the Steinberg Download Manager attempting to “reinstall” the eLicencer once a user (like me) has already migrated to Steinberg Licencing.

I seriously do not understand your pointed messaging OR the need for this useless software if using Steinberg download manager to service software updates.

And yes - I know I can download the updates standalone but this fact is NEVER promoted as all you guys constantly tell the userbase is to use Steinberg Download Manager for all of this stuff.

Truly disappointing.


Interesting as I just installed now and it didn’t do that. In fact it was really quick.

What was confusing is all the info on not using the usb elicencer anymore. I didn’t realise it was even an option in 11! I had to think really hard and check my authorisation manager to see that my Wavelab was already authorised to my computer as I couldn’t remember back to when I got it. Anyway working fine but that was really confusing.

Yea, I would have no issue with SDA asking me if I want to add it when booting it up, but it instead auto-installs it any time it’s not there - even if you have nothing on your machine that requires it.

WaveLab Pro was USB Dongle-only up until 11.1, when it moved to Steinberg Licensing.

Before then, not even the soft eLicenser was an option :stuck_out_tongue:

Installation failed…
I updated the download assistant and did everything else I can think of, but no joy.
Thought maybe uninstalling 11.0.1 might work, but nope.
It seems the installer can’t locate the installation media.
It put the exe in:
“C:\Users\QB\Downloads\Steinberg\WIN64\WaveLab Elements 11.2 (Full and Update Installer)”

Any assistance greatly appreciated.

Forgot to mention…
I’m on Windows 10 Home - 22H2 - 19045.2604

I have the same problem!
Error code 1612. Windows 11.

1 Like

All good here, regarding the update.
Where is a full list of improvements an new features?

This is a small update mainly with bug fixes.
However, 3 features (that have been forgotten to be added in the PDF history), are these:

  • New error correction method “Smooth Pencil Line”
  • Audio Editor Volume Envelope: the waveform peaks now follow the envelope
  • New Track Lane Shortcuts

Thanks for the update , installed without an issue , have you tweeted the Gui or is it my eyesight ?

I don’t see what you mean, and the GUI should be the same, apart from a few icons that had not enough contrast in the dark theme.

Ok Thanks PG1 , it must be working under Cubase for a few days . But all setting were remembered after the update so everythin g fine here

Quick install here (already using the Activation Manager), settings remembered and working. Thanks for the update! Win11 22H2, OS build 22621.1265.

Try changing the download location in SDA, for example, make a folder called C:\Steinberg, and point the SDA to that, and re-download. The installer also needs to be run with administrative privileges.

1 Like

:frowning: quote=“MrSoundman, post:17, topic:836414”]
Try changing the download location in SDA, for example, make a folder called C:\Steinberg, and point the SDA to that, and re-download. The installer also needs to be run with administrative privileges.

Nope… - didn’t work :frowning:

Thanks for your response.
I did as you suggested (and even tried several different locations) but got the same result.

The installer seems to lose track of the location of the unpacked installation files.
It starts installing, unpacks everything to:
C:\Users\QB\AppData\Local\Temp\RarSFX1\WaveLab Elements 11\Additional Content\Installer

It starts installing and then throws up the “Installation Source not available” error dialog.
(Oddly enough, it installed the ASIO driver update no problem.)

I launched Wavelab and it works fine, but is still 11.1.20 (Build62).

I tried running the Setup again and choosing “Uninstall” in case there was some dud registry keys or something, and it shows the same dialog…presumably not in error this time since it’s not installed.
Screenshot 2023-02-28 173822

I dunno at this point. :thinking:

Same here…
Wavelab Pro.

Sorry you’re having the same issue, but it’s a comfort to know it’s happening to someone else on W11, and it’s not just me on my fairly tweaked W10. :wink: