Wavelab 11 Replace with command loses edits

The Tool Windows>File Window command “Replace With” replaces file clips with entire file duration. In Wavelab 10 , “Replace With” replaced the audio-file referred to by a clip while maintaining all edits, and plugins. This was handy when say replicating a complex edit sequence with a remix. Now the audio file to which the clips point is indeed replaced by the new file, the plugins migrate as expected, but every clip will be substituted with one that is the full length of the source file and rippled.

If the file is already open in the montage, it is impossible to execute a replace with command on other clips to point to the same source file.

Example: I have a song with vocal up mixes cut into the choruses. The verses are vocal normal. My client remixes the song with more bass. I select all the chorus mixes and execute the “replace with” command and point to the new vocal up-bass up remix. All the choruses are substituted with clips of the entire song. Now I want to select the verses, and substitute them as well with the vocal up-Bass up mix. I select the verses and execute a “Replace with” command and point to the vocal up-bass up remix. Wavelab 11 fails and throws the error “file already open in montage”.

All this stuff worked great in Wavelab 10. I set up two custom shortcuts “Alt-F, C” to select all clips that reference a file. And “Alt+F, R” to replace the selected clips’ source file. I used these commands all the time to quickly duplicate previous edits with remixed sources.

Please fix.

What you describe is caused by the following option. Check it OFF, and you will have the WaveLab 10 behavior back :slightly_smiling_face:.

By default, this option is ON. Maybe that’s a mistake.
Actually, there are cases when the option makes sense and some others where it does not. Maybe WaveLab should be a bit smarter and should consider this option OFF if the new file has precisely the same length as before.

1 Like

I remember a number of users being surprised by this change and had to go and turn it off and they were happy again.

Anyway, I have now changed it (next minor update), so that if the new file has the same length, then there is no clip resizing in any case (hence whatever the option). This was already the case when substituting a file directly on the clip, but not globally, as reported by @kenbobplus3db

Brilliant- didn’t know that switch was buried down in the prefs. File substitution is working better now.


I still get an error when I try to replace files in clips that may already be open elsewhere in the montage. Consider the case where one might replace one clip in a montage with an alternate mix to test whether the change is useful. Then when selecting the rest of the clips, a replace with is blocked because the test clip is already “pointing” at the desired source file. Even more distressing, substitutions are blocked on single clips as well. The only work-around I can see is to copy/paste the edit assembly onto another montage, do the work on the isolated song, and then copy/paste the assembly back into the original montage.

An improvement in functionality seems warranted: The replace with command seems to work on all clips which reference a file. It would be more useful to have a “replace selected clips” option.

Do you mean you get a message that says exactly: “This file is already used by the Audio Montage.” ?

That is the message, and then in blue below it shows the pathing to the file source.

In cases of a processing dependency, I could see this making sense; but this is not the situation where one iteration of the clip requires that a file open for edits be released from processing.

This message appears if you try to replace an audio file with one which is already used by clips in the montage. This is a particular case that is currently not possible. But I will make it possible in the next minor update.

1 Like