Wavelab 7: Bug with RF64 file support (?)

Hi,

first: Sorry for posting in the “Forum Issues” forum instead of the “Wavelab” forum. (I couldn’t manage to post in the latter forum because I’m using my private account but Wavelab is registered to my employer…).

Well… I think the support of large audio files in Wavelab is buggy. Precisely, I tried the following:

    1. Activate RF64 support in the options
  1. Open a large stereo MP3 file (25h, ~1.4GB) -> no problem – all samples are available.
  2. Save the decoded (by opening the file) data to
  • a) a wave file
    b) a w64 file
    c) a raw file

The resulting file is ~15.8Gb.

In every case, the first part of the audio data was not saved. All three files contain 1,821,646,847 (digital) zeros in each channel before the actual signal starts. The overall duration is correct, but the content of the first ~11h28min27s is missing. The headers also seem to be correct (“RF64…” etc.) – on first sight at least – but the audio data in the files starts with only zeros…

Then I tried converting the MP3-data to raw format using Audacity (which uses the libsndfile library I suppose). The resulting file looks okay – at least there are no zeros at the beginning… Opening this file with Wavelab yields the same result as above (first part missing), whereas opening it with Audacity works without a problem. I conclude that the data is stored correctly, but Wavelab seems to have trouble reading it…

Lastly, I created an RF64 file with Audacity – again from the same MP3-data. Again, the file opened with Wavelab has the correct length, but the first ~11,5h are missing (digital zero). Opening the file with Audacity works without a problem…

Apart from the procedure described above, I really think I tried every possible way to save and load the long signal with Wavelab but – after several hours – couldn’t find a way to make it work. As a consequence I guess there’s a problem with Wavelab’s file read and write routines…

Or am I doing something (fundamentally) wrong?


Cheers and regards,

Karl


PS: My operating system is Windows XP (32bit), my temp and cache folders are on a hard drive that is NTFS formatted, as is my C: drive. And I’m using Wavelab 7.11.