Wavelab 7 not burning ISRC codes correctly...

This is odd. Wavelab 7.
I’m mastering a project from the montage. I add the audio files and then use the CD Wizard to assemble the CD. I also add the UPC and ISRC codes. I close the wizard and then add the CD Text. Sounds pretty straight forward.
I burn a CD and then check the CD by using the ‘import audio’ to make sure all the text and codes are fine. Turns out the ISRC codes are wrong; the first two letters come up different. Tech support says it could be the burner but it’s not random; it’s in the same place every time.
I’ve made new montages, burned from a DDP and from the montage and it persists. I’ve just reinstalled WL7 and it’s still there. I sent a short DDP file to tech support and it worked fine for him. So the DDP is accurate but it burns inaccurately. And the cue sheet shows it correct also. I have a third party analyzer and it shows the error.
I just can’t figure how a burner could do this.
Anything here sound familiar? Can Wavelab or Windows 7 being sending information to the writer incorrectly (but consistently)?
Help would be much appreciated.
I have an 'HP Combo 240d" writer; it’s fairly new.
I’m running Windows 7 Ultimate with a full version of Wavelab 7.

My guess is that the problem is not on the burner side, but on the grab side. We have met several optical devices (incl. Plextor) which are not able to import ISRC codes correctly (the same drive burns the codes correctly, but does not read them correctly).
My recommendation is to try with another drive.

Hi Edipro. After reading your post I checked with my two cd burners. I normally use an external usb LG burner. I have never been lucky with internal cd burners. If I check the isrc codes with my internal dvd burner they are incorrect. But if I check them on my LG they are perfect (the cd was burnt on the LG).
Try the “import audio cd” from another cd burner if you can. Maybe they are saved correctly on the cd but you see them incorrectly when you try to import them.

Thanks to both who have responded. Both replies are pointing to the same solution. I have to get another CD drive to read the disk; it’s on the way and I will let you know how it works out.
Thank you very much for your fast reply.

Well gentlemen, many thanks for your help. As you said, the disk was written perfectly; my cd reader was faulty. I just installed another writer (LG) and it works (and reads) properly.
Thanks again.

I am glad you solved the problem.
Can you please tell me which LG model you have installed? I want to change my internal writer, Pioneer. It doesn’t burn and read properly.

Sorry I missed your post; I was away for the last couple of days.
A friend brought over an LG (HL-DT-ST DVDRAM GSA-4120B ATA). It came out of his spare computer so it’s not new but it works fine. I don’t think it’s too old though. There may be an updated model on this by now.
Hope this helps.

Thanks. I have never been lucky with internal writers and WL. My usb LG works great but I don’t know why I have never bought an internal LG.