WaveLab 8.5 x64 weird crashing

Windows only update, to solve a compatibility problem with Microsoft OneDrive.

Noticed I’d been having crashes with WL 8.5.30 64-bit on Win 10, but running WL in admin mode seems to work.

i disabled onedrive and running it in admin mode and it works for me too!
thanks for the hint!

Thanks Guys - this crash at start-up on Win10 64bit got me tonight too.
I disabled OneDrive & WL still crashed.
Run WL as administrator and all is well.
Need it tomorrow so it’s a good thing I found this thread tonight !!

I’ve been having the same startup crash problem all week.
Pulling my hair out trying to find the problem.
I had just upgraded some of my hardware (MB, CPU, memory, SSD).
So thought it was caused by something I did with hardware or OS re-install.
Decided to try and download a fresh copy of Wavelab and at the same time checked the forum.
32 bit works OK and 64 bit doesn’t, just as reported.

We provide a solution soon. Just a matter of packaging it.
Did you try running WaveLab in administrator mode?

removed

This has now started to happen to me, and yes, there was a forced update to OneDrive which seems to have caused it. This is not funny. I don’t want OneDrive, I’ve never used OneDrive, I don’t intend to use OneDrive, and yet there doesn’t seem to be any way to uninstall it, or to uninstall the update that has caused this problem.

… and so it has come to pass. Everything the scaremongers warned about. Microsoft decide to make a change to my computer and in doing so, cripple an important application. I can’t undo the change, and I was given no warning it was going to happen.

Bring on WaveLab for Linux, I say.

I am heading back to Windows 7 ASAP after this debacle…

VP

I disabled OneDrive using Local Group Policy and now WaveLab 8.5.30 x64 is working again.

[EDIT:] Spoke too soon :angry: … now it’s crashing again, but this time it’s different, in that it’s an actual crash in nt.dll, whereas before the process stayed running in the background with no GUI appearing.

Luckily I was able to fall back on my WL Elements (8.0.4 x64) on my laptop (also W10x64) which doesn’t appear to be affected.

Hello All - This is my 1st post

For the past (2) years I have used WL Elements 8 for basic editing, compilation of podcasts, music/sound tracks. I purchased licenses for a desktop and a laptop. The work sessions sometimes go all night. The point is this: During the many work sessions, not once did Windows 7 or 8.1 cause WLE8 to crash; this is not true with Windows 10.

It seems like the crashing started about (3) weeks ago and I have had to reproduce work. I used Visual Studio 2013 to capture the crash data and each report states:
“Exception Information: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.”
The info basically confirms that OneDrive is the culprit.

For me, the best fix was to completely remove OneDrive from the OS. Since removing that AppPackage, I tried my best to crash-out WLE 8. Thankfully, the Steinberg software is as sturdy as ever.

When I am really busy, I hate the idea of another learning curve. But since we do not live in a perfect world, I did the research over this past weekend and got a simple .bat file to completely remove OneDrive. It is the text file that I uploaded as an attachment. If anyone wants to use it, like always - be sure and back up your existing system image for good insurance.

The attachment is only a text file. I must be saved as a .bat and run in an elevated command. I put a couple more notes in the file to help as necessary. Actually, I’d copy/paste the code into a fresh text document and then save it as a .bat. When opened, you can read each line of code and see that it is safe.

Furthermore, I have made other commands for use in Powershell to remove other AppPackages out of Windows 10 that provided no value to me like Xbox, Maps, and all the other BS that Win10 came packed with. If anyone is interested, please reply and I’ll make a list of the commands.

Regards,
Ryan

I do not see the attachment I uploaded and I checked the attachment control panel - not there either.

Take the below information and copy/paste into a Notepad text file, save it as a .bat

Run it under an elevated command.

Here’s the code to remove OneDrive from Windows 10:

@echo off
cls

set x86="%SYSTEMROOT%\System32\OneDriveSetup.exe"
set x64="%SYSTEMROOT%\SysWOW64\OneDriveSetup.exe"

echo Closing OneDrive process.
echo.
taskkill /f /im OneDrive.exe > NUL 2>&1
ping 127.0.0.1 -n 5 > NUL 2>&1

echo Uninstalling OneDrive.
echo.
if exist %x64% (%x64% /uninstall) else (%x86% /uninstall)
ping 127.0.0.1 -n 5 > NUL 2>&1

echo Removing OneDrive leftovers.
echo.
rd “%USERPROFILE%\OneDrive” /Q /S > NUL 2>&1
rd “C:\OneDriveTemp” /Q /S > NUL 2>&1
rd “%LOCALAPPDATA%\Microsoft\OneDrive” /Q /S > NUL 2>&1
rd “%PROGRAMDATA%\Microsoft OneDrive” /Q /S > NUL 2>&1

echo Removing OneDrive from the Explorer Side Panel.
echo.
REG DELETE “HKEY_CLASSES_ROOT\CLSID{018D5C66-4533-4307-9B53-224DE2ED1FE6}” /f > NUL 2>&1
REG DELETE “HKEY_CLASSES_ROOT\Wow6432Node\CLSID{018D5C66-4533-4307-9B53-224DE2ED1FE6}” /f > NUL 2>&1

pause

While this seems like a good stopgap measure - for now - you may be setting yourself up for more unknowns in the future as Microsoft force feeds you more updates without your consent.

As was the case with many of us removing those Windows updates from this past summer for Win 7 that placed all the “Get WIndows 10” crap on our drives - it was all replace over and over again as MS found new ways to detect it was missing.

I have no doubt that ongoing changes to Windows 10 - especially this big Threshold 2 update coming soon will place OneDrive right back on any machine that has it removed.

This is one huge reason why Windows 10 won’t see action here anymore. I can’t have OS changes killing my key apps when I need them most.

VP

I just ran into the same problem last week. I was using Wavelab 8.5 64 bit. I did a system restore to before the last Microsoft upgrade and reinstalled Wavelab and it worked. When the windows upgrade came it stopped again. I can still use Wavelab 8.0 64 bit or 8.5 32 bit but really want 8.5 64 bit. I also tried upgrading to 8.5.30 but had the same problem. I do hope the fix comes soon.

@RKnowles, thanks for the tip on how to remove OneDrive (or, as I like to call it, “NSA’s Little Helper”), but as Bruce points out, today is “Patch Tuesday” so who knows what Microsoft will rain down upon my computer (well, actually, it’s now their computer, isn’t it?)

I know this isn’t Steinberg’s fault but perhaps an email notification could go out to registered users when this sort of thing happens? (Perhaps there’s already a list and I’m not subscribed to it). Spent all morning so far cleaning up my PC and uninstalling/reinstalling Wavelab 8.5.30/64 - guess I should have come here first!
One tip though for 64-bit users - when I right-click the shortcut and run it as Administrator, it works!
Cheers, Paul

@RKnowles, you instructions on how to remove OneDrive have worked! WaveLab 8.5 on W10x64 is now back in action. Many thanks again!

A hotfix addressing this issue has just been released:

WaveLab 8.5. download page

Cheers,

Georg

Just for information, I installed all updates offered today (November 2015 patch Tuesday) and following RKnowles fix, OneDrive was not reinstalled by the updates and WaveLab 8.5.30x64 is still working, so that’s another option (after all, the hotifx comes with the warning “Please note that hotfixes do not go through the complete testing process. Technical support cannot be granted and installation is done at your own risk.”

Thanks nevertheless PG and Steinberg for the fix.