Wavelab 8 64bit does not see my DVD devices ...

Hi, Wavelab 8 64bit on Windows 7 Ultimate 64bit does not see my CD/DVD writer and rom drives. Winaspi32.dll is present in both SysWOW64 and Wavelab folders itself, and other programs work perfectly with my DVD devices. Wavelab sayz “no device” in the appropriate drop down menus. I reinstalled Wavelab, still no sho’ … Any tips? - F

Winaspi32.dll is not used by WaveLab 8 and should not be found in the WaveLab folder.

Maybe this is an installation problem. I advise to download “Driver_Installer_x86_x64.exe”
from this page:
http://www.gearsoftware.com/support/drivers.php

and run it.

Hello Philippe, thanks, i tried that already, no show still. Also tried the common registry edits, no go … as for the DVD writer i have for 2 years now is a very common rock solid proved & working ASUS DRW-24B3LT that never lets me down, and worked with Wavelab 6 OK. No 2 is an also common LiteON DVD Rom ATAPI iHOS104, also OK and with Wavelab 6 too. They have the latest drivers for my setup, and are installed and recognized by name in Windows 7 64bit and Everest BTW. Has it anyring to do with ATAPI or ASAPI & 64 bit windows? … PS Cubase 7.5 64bit recognizes my DVD hardware OK. - F

Here one can verify if a driver is properly installed:
http://www.gearsoftware.com/wiki/index.php?title=Determining_if_GEARAspi_drivers_are_installed_correctly

But I think the problem is caused by a conflict with some other driver in your computer.
The WaveLab 8 driver is generic and does not change behaviour with the model that is found your your drive.
The fact that you say Winaspi32.dll is present in the Wavelab folder is not normal.

Hi Philippe, i put it there my self as tip i read somewhere, and as experiment, just took it out, dunno if it belongs in the SysWOW64 folder in Windows, left it there for now, Wavelab still sayz “no device” … i had my DVD devices de-installed BTW, and reinstalled by rebooting through device manager, makes no difference … puzzle, maybe i should check settings in the registry, but then one has to know exactly what’s needed. Just finished editing and old imported audio CD with wavelab, with CD files imported via Cubase, detour takes quite more time … PS i ran the downloaded Gear thing, it seems nothing installs as the Gear driver does not show in Driver File Details, only cdrom.sys from windows. I’ll look in to that later and let you know, thanks, -Nout

Hello Philippe, all the Gear drivers were installed OK, it seems all settings in the registry are OK with the UpperFilters addressing the right drivers present in the right places. Activated manually the GEARAspiWDM.sys with autoruns. Re booted – but in msinfo32 this line: “gearaspiwdm GEAR ASPI Filter Driver c:\windows\system32\drivers\gearaspiwdm.sys Kernel Driver No Manual Stopped OK Normal No No” seemed to indicate things were not running. I give up. - thanks Nout

It might be an issue with the controller on the motherboard that your drives are connected to.

My SATA optical drives don’t show up in WaveLab 8 x64 unless I set the SATA controller to IDE emulation mode in the BIOS. Luckily I have a motherboard that has a separate 2-port SATA controller for the optical drives, otherwise that setting would kill the performance of the hard disks.

It also occasionally happens that the drives “disappear”, and then I have to reboot. I have to ask the obvious: have you tried totally rebooting, right down to powering off and back on again? These days I seldom actually reboot, instead I “sleep” the computer as it uses less than 0.5W that way.

Most of the times i power off completely, saves ventilators and dust collecting too i hope also, and i don’t think i want to mess with one and other in essentials like sata setup etc, just for one buggy program; all my other CD & DVD stuff works flawlessly … I have an ASUS PT6SE i-7 fitted motherboard, quite standard me thinks BTW. But i’ll look into your suggestions. Seems once again that windows is a too complicated platform for a simple user like me, i remember those Atari days well, and Windows XP seemed even straight forward compared to modern times. Would love to see Chaplin making a new movie now. BTW with a car operating and error-ring like windows 7 does you’d drive into a ditch without a glitch … thanks, Nout

Just by chance, try resetting the WaveLab preferences by erasing the folder:
C:\Users[UserName]\AppData\Roaming\Steinberg\WaveLab 8\

Hi Philippe, just did, it searched plugins etc, but still “no device” … Do you ever sleep BTW? I am going to log off for the nite, thanks -

And now i am truly FLABBERGASTED … started my PC fresh this morning, and wavelab 8 sees my burner … why not yesterday? I changed nothing no mo’ ! - Thanks for all your help guys !! - Nout

Wavelab waits for the right moment to surprise you… :sunglasses:

I had the exact same experience with the trial version of WaveLab Elements 8 under Windows 7 just now: no DVD drive at all showed up in WaveLab’s “Write Data CD/DVD” “Device” field.

I think the suggestion to try shutting down and restarting Windows should be included in the FAQ at page https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/cddvd-writer-issues.html.

Thanks