Wavelab 8 Crashing On Startup

Thanks PG,

I ran Tracer.exe and all that comes up is this…

A70: ////// WaveLab Diagnostics //////
A70: WaveLab 8.0.1 (build 665)
A70: Operating System: Windows 7

You said earlier:

Here when it hangs the window is the “Audio Files” window."

then it’s not possible to have as little info as what you show. Pleasee my previous post and activate the exact same options. Then you will see more trace messages…

I think I found the problem but not sure of the cause. Maybe one of two things. WL8 is working now. A few years back I had a project come in on Pro Tools. I installed Pro Tools 9 and the hardware unit drivers for the latest version of Avid’s M Box. I uninstalled both Pro Tools and the hardware drivers and WL8 opens now without any issues.

Good to know.

I have been trying to follow this thread as I, too, have the same problem…W8 is crashing on startup. I downloaded your png but I don’t see how I can get to the diagnostics when it won’t let me open the program. I’m not sure what holding the Alt key is supposed to do; it just opens up the properties of the icon for me; I’ve even went right to the program file itself (not the shortcut icon).
So here’s what I have:
I’m running both 32 and 64 bit Win 7 Ultimate on an i5…the 64bit W8 works fine but my UAD cards are 32bit, so that’s out. I actually only put it on the 64 bit side to practice the install first.
I have an RME FF400 soundcard. I tried disabling the internal soundcard, but nothing changed.
I do have PT9 though. Do I have to uninstall that and reinstall? I don’t use it much since Cubase 7, but I don’t need another problem. I recall jumping through hoops for that install too.
I hope this can be resolved fairly quickly as I’m looking forward to working with it this week.
Did I see a version 8.01 or is that what I downloaded?
Albert MacDonald
Toronto, Canada

Try to uninstall PT9.
Else open WaveLab 64 bit, as you can do it, and activate the diagnostics from there. They will be active when you run WaveLab 32 bit.

UAD cards are 32bit

Don’t they have a driver that works with 64 bit?

I guess WL8 hates PT9. I came to work this morning and was unable to even open WL7. I uninstalled both 7-8, then PT9. Both 7 and 8 are working, but 7 (build600 7.2.1) looks different. I can’t access the solo or mute buttons in the master section now. They no longer exist…

I can’t access the solo or mute buttons in the master section now. They no longer exist…

What do you mean? They are still there. Please show me a picture of what you mean.

WL7 Master section no buttons.PNG
Here you go.

Simply activate this option:
2013-05-08_22-30-08.png

:slight_smile:…Thanks!

I have 2 UAD1 cards and there are no 64bit drivers for them.

So here’s what I did while I was away.
Instead of uninstalling PT9, I moved it to another drive; I them removed all of the registry files and saved them.
I then opened W8 successfully, but with messages referring to Avid. I just cancelled them and W8 seems to work fine.
I then closed it, replaced the program and it’s registry files. It’s now back to the original problem.
So is there a way to fix this inside W8 now that I’ve found a way to open it?
I’ll send you the two screen shots. Page one is the first error and page two, the second.
Hope this helps.
Albert
W8 error page 2.jpg
W8 error page 1.png

Look in the registry at this key:
HKEY_LOCAL_MACHINE\SOFTWARE\ASIO

WaveLab will try to load these drivers at startup.
You could try to temporarily remove these keys to see if that changes something.

PERFECT!!! You got it. So here’s what I did.
I went to the registry location; I exported only the Avid folder to my desktop, then deleted it in the registry.
W8 opened perfectly. Everything appears to be working.
I then opened PT9 and it works perfectly. (???) Not important so long as it works.
I then closed PT9 and reopened W8; still works.
I reopened the registry and it still has that folder missing; it doesn’t seem to matter.
I then restarted and everything is still working.
Thank you very much for all your help. Looking forward to digging into W8.
Cheers,
Albert

Hi Phillipe,

I have the same problem, WL8 64bit freezes on startup(error=AppHang2)
By removing the problematic driver(only problematic with WLab) via

Look in the registry at this key:
HKEY_LOCAL_MACHINE\SOFTWARE\ASIO

WaveLab will try to load these drivers at startup.
You could try to temporarily remove these keys to see if that changes something.

WLAb starts.
This problematic driver is working perfect in Cubase 7 64bit and I need it there, but if I remove it via the above method I won’t see it in the ASIO DRIVER dialogue anymore. Is there a way to keep WLab from loading certain drivers without taking them off the general Asio “pool”?
cheers Rolf

No it’s not possible. What is your audio driver?

Hello,

the problematic driver is SonicCore Scope X-ite1 64 bit, the other driver is a Fireface 800 64 bit, no problem there. It used to work and I didnt change anything, as far as I remember(been on tour for 2 month).
Maybe some win 8 “updates” happened unnoticed. I can change it but that would mean I cant use Xite at all if I want to use Wavelab:( Would be nice to be able to use both, though.

thanks Rolf

I see. There is a fix available for this driver. Do a search in the wavelab 7 forum and you will find a regstry file to downlad. This will fix your problem.

Hi Philippe,

thank you so much:). I have used this fix before…I simply forgot.:frowning:

cheers Rolf

Hi. I was trying to use the trial and it crashed in the exact same manner. I have no asio drivers. I am using WL8 64-bit under windows 8.

Any ideas?