WaveLab 9.5.30 Update available

Same DDP installation error here.
WaveLab Pro update works. DDP update error 1636.
I’ll wait for the fix. I am not going to uninstall any WaveLab version for that.

You have to wonder if any of these packages are actually tested in the real world…

I was excited to see an update - but not so much now.


I updated a few hours ago and experienced no problems. This update has also fixed the problems of NI plugins crashing the application.

They are and there where no known issues.
For me it’s running stable, no issues since install/update.

i’m getting crashes with the new update… twice today so far…

first was saving a montage and switching between the two file type buttons (forgot what they are off the top of my head)… in the save dialogue… like PROJECT and… something else… (sorry, forgot the names)

and again a crash just now… having left wavelab and came back to it after about an hour i can’t switch to it and it’s “not responding”…

the only fix so far has been to restart my mac. force quitting quits, but i still can’t re-open it until i restart… and, even this last time, i couldn’t force-quit wavelab… so it was holding up the restarting of my computer… had to use the power button.

i know this is pretty generic and not specific… i don’t expect a solution from this thread, but thought i’d just point out general crashing that i never had with 5.20

Ok just tried myself and getting the same error. The workaround is not one I want to use. I don’t want to uninstall and re-install again. Things get lost this way. Can you please put a new updater out to fix this problem it is nearly a month since the release of this patch. That is just shoddy service

A new patch is coming this week.

I’m getting crashes also. Seems to involve plugins for me (VSTs). At a certain point in the session if I try to expand a plugin to edit its settings Wavelab crashes and I lose all my edits! Has happened 4 times last night during a session, meaning i had to save every time I made a significant edit (of course meaning I can’t go back if I decide two edits later that I was going down the wrong path). Becoming unusable for professional work I’m afraid.

The only ‘fix’ is to reboot the Mac. Very frustrating.

I’m on El Capitan, MacBookPro 2015, RME Babyface Pro. Seems to occur with any plugin, even Wavelab’s own.


What plugins are involved?


It doesn’t matter - It crashes with Steinberg’s native ones, Izotop 8, SoundToys…seems to just be any vst tbh.



Weird, never heard about this in WaveLab 9.5. Please upload a crash dump in PM.

Strangely seems to subsided now?! If/When it happens again I’ll definitely PM a crash dump to you.