Wavelab 9 and 9.5 both hang/crash on playback

I’m experiencing a hang/ crash in both WL9 and 9.5 (latest versions) whenever I engage the audio driver. Program boots up fine, and I can get around all the windows with no issues. However, I preview a file, load a file and then press play, go to the Audio Preferences tab, or do anything else that would engage the audio driver, I get a hang/ crash. I’ve tried trashing prefs, unplugging UFX to force another driver, but no change. Any ideas?


RME UFX+ (latest USB driver a/o Apr 3, 2019 - madiface Win 09681)
Windows 10 Pro for Workstations (1809)
OS Build: 17763.379
Dell T7910 Workstation
Intel Xeon Gold 6130 CPU @2.10GHz (32 cores)
64-bit, x64 proc


did the problem newly occured with the mentioned audio interface ?
Can you try to select the MME Driver and check if it will be also crash?

thanx and cheers

It is also worth checking the buffer on the RME hasn’t re-set itself. This can happen following a Windows or other update.


When you say, “reset the buffer,” are you referring to the buffer size resetting?

So far, I haven’t been able to access Audio Connections without it hanging, so I’m not able to change the driver from within WL. I did, however, disconnect the UFX to force it to start with another driver, and it displayed the same behavior. Same hanging.

Look in the registry at this key:

WaveLab will try to load these drivers at startup.
You could try to temporarily remove these keys to see if that changes something.
One solution is to erase the CLSID variable.
Later, whether you paste the values again, to restore the info. You could also reinstall the drivers.

Thank you- I’ll try that. I’ve reinstalled WL and the RME drivers with the same result. The registry and CSLID variable fixes are good ideas- thank you.

That worked - thank you!!!

WL seems to have no problem now playing out through my UFX+. So now… do I need to now reinstall the drivers, or will the keys automatically repopulate?

do I need to now reinstall the drivers, or will the keys automatically repopulate?

Reinstall only if something is not working.

Yes. But I see that all is good now.

For what it’s worth, I’ve had this behavior as well. I’m using a Babyface pro, with the latest RME drivers on the latest version of wavelab elements. This issue is also present with the previous driver & wavelab version.

I somehow managed to get Asio4All loaded up & that’s been working, but it’s not ideal because sometimes I go back & forth between wavelab & cubase & the driver switching is troublesome. No issues with cubase pro, BTW.

In any event, I’ll try the regedit. Cheers