Wavelab 9 Elements Trial

I’ve just downloaded and trying out Wavelab 9 Elements. However instead of it using the 30 days trial license its eating on my All Application trial license which is only a days worth of time.
I wasn’t asked to input my email address on download of this trial (unlike say Halion where I was given a trial key to enter and use).
Did I miss a page? Anyone else had this or know where I went wrong?

Edit It is on my soft e-license but not on my usb-eLicense??

Can’t you decline when it asks to use your All App trial license? Or pull out the USB elicenser with the All App trial license before starting WL Elements.

Or “Run Maintenance” in the elicenser Control Center

Running Wavelab trial without the USB key runs on the 30 day trial But then like that I can’t run my other products.
I’ve also tried to run maintenance which didn’t help. And when I decline the app closes.
It’s a very strange problem.

I’ve also tried this, but it wont let me drag and drop. Sorry to trouble you, just don’t want it to eat into the All App time.

="Videre"I’ve also tried this, but it wont let me drag and drop. Sorry to trouble you, just don’t want it to eat into the All App time.> https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/how-to-transfer-a-license-from-soft-elicenser-to-usb-elicenser.html

Sorry I don’t know, because it looks like it should drag and drop. I would download and install the latest elicenser software, if you haven’t already.

And I would think there is another way to transfer, I mean, via a menu command maybe?

Ok so the issue has changed a little, this is the pop up I get when I am trying to trial Wavelab.
Does this make any sense? I’ve tried all the things like performing maintenance. Ect. And if I click activate it asks for the code, I enter the code it says I’ve done it already with a big red cross. Then closes down on me. And that seems to be the cycle?

When I said it’s changed, this is still the same type of problem as when we tried to test drive elements.

Here is an image of my license

Update, seems like the timer does not go down. It just alerts you.