Wavelab 9 Time Stretch issue

I am a loyal user of Wavelab for many years. I realized today that when time stretching a sound, in this case 86 bpm to 128 a artifact shows up in the beginning of the file and throws the timing off.

Best / Average Time Freq

https://www.dropbox.com/s/kakrt9xfqsw10rx/Screenshot%202016-12-29%2000.36.19.png?dl=0
https://www.dropbox.com/s/rgmw0n2cjyq0m6n/Screenshot%202016-12-29%2000.37.04.png?dl=0

You can silence it with a simple process, no harm!

This is not about a silence issue. It is about the fact that it throws the initial start timing off.

It’s impossible to tell what’s going on, since the two screen shots have a different zoom level and a different cursor position. Can’t see what the artefact is you refer to. The red arrow you show is in the earlier screen shot, so is something removed?

It is creating a artifact in the beginning of the file witch is in essence delaying the timing of the edit start point.
It is not impossible to see what is going on but I did think of that after uploading.

Here is a very simple example.
S=Start
E=End
A=Artifact
-= Audio Data

86 BPM (Original)
S----------------------E

128 BPM (Time Compressed with average pitch and time at best quality)
A–S----------E

Do you mean the result has the wrong length? How do you know it’s an artifact?

The result has additional info in the beginning and that can affect the length and start sound (Pop). The problem only happens when the stretching occurs on a loop that starts exactly at the beginning of the file. I experimented in adding some space in the top and the results are better.

https://youtu.be/rCNO8MDpoHo

fwiw, I was able to reproduce your original problem. The time stretch flattens a 30ms section (given my stretch factor) just after the starting waveform of the left edge, if you use the highest quality setting (Best Slow), and to some extent if you use High or Standard. If you use the Quick Process setting, it doesn’t do it nearly as much, if at all.

It’s the same in Wavelab 8.5.30.
Original.PNG
After Best Slow.png
After Quick Process.PNG

According to my tests, the full length is always ok. This is not “added” audio. I could not produce any “click” either.
Did you try various TS methods?

PG, I agree, it’s not added audio, and the length is ok. But there’s something else going on.

I’ve made a composite of my two timestretched pictures. The timestretch “Quick Process” (the pic on the bottom) is correct. The timestretch “Best Slow” (the pic on the top) is wrong. The Best Slow (and High settings) are doing something funny from about 12ms to 42ms, reducing the level greatly, and sometimes causing a “click”, as the beginning waveform (which is correct from about 0 to 8ms) goes down to almost a flatline, way down in level for about 30ms. Then they start to look more alike after 42ms to the end.

Sorry about the picture resolution, it’s the best I could do right now. Hope you can read the numbers.

I see the same thing with the timestretch in Wavelab 8.5.30.

composite (2).jpg

I will have to report this to the company providing DIRAC.