Wavelab and Slate Digital FG-X

Has anybody succeeded to get Slate Digital FG-X to show up in Wavelab 7 Win7x64 ? Works fine with Nuendo 5 but WL7 doesn’t recognize it. This might have something to do with FG-X’s iLok copy protection?
Does anybody know mastering/CD burning program working w/FG-X in 64 bit Win7 ?

Any info would be great.

Yes works here in WL7 no problem

Same problem here. No matter what I do (followed the suggestions on their website), I can’t get it to show in Wavelab 7 with Windows 7 - 64bit. I think they’re working on an update - maybe that will work.

You have WL7 on Windows 7 64 bit machine?
Could you tell us where your WL is installed (program files/program files x86?) and in which VST folder is your FG-X dll installed, this would help us unlucky alot :confused:


everything suggested default install dirs, and yes W7 x64, however did change the visual basic runtime to MS latest version and deleted all older versions

I don’t have FG-X, but have the same issue with WL7 on Win7 64bit and iZotope RX2 plugins not to show up.
Since FG-X and RX2 use both iLok/Pace protection…maybe it comes from there in conjunction with Win7 ?!
As far as I remember all works fine in WinXP and WL7, but I had to switch to Win7 because of new PC.

Well that’s what I was thinkin too, however FG-X works fine with Nuendo 5 (64bit) in same PC… :unamused:

Problem solved. Installed FG-X (and Trigger) as 64bit AND 32 bit versions. Put 64bit dll’s to Program files(86x)/Steinberg/VSTplugins (default) and 32bit dll’s to Program files(86x)/VST (also default setting).
Both FG-X and Trigger work now with Nuendo 5 and Wavelab 7. Me happy :wink:

Well, I finally got it to show up in ‘Cubase 6’ by ‘adding’ another VST plugin folder ‘specific’ to Slate Digital. So, now it works inside of Cubase - but not Wavelab. I can set an ‘alternative’ plug-in folder in Wavelab (but only one). And I can’t change this alternative becuase it points at ‘Autotune 7’. This has to be set to this Autotune folder because that was the only way of getting it accept Autotune after around 3 months of problems.

Both iLOK related problems I think.


Just moving dll’s to new folder did not help me but good to hear you have some success…
Have you tried to install both 64 and 32 bit versions of FG-X? Like mentioned on my earlier post, just moving/renaming folders did not work with WL.

Hope this helps,


Yes - I did an uninstall. Then, installed both 32 and 64. They’re just invisible to Wavelab. I even tried to install to the Autotune folder I created. Inside the AT folder is the dll for Autotune. I set this as the alternative VST path in Wavelab so it shows up. But, even inside here FG-X doesn’t show.

So, I create a Slate Digital folder next to the Autotune folder - and this deosn’t work. Oddly, when I force Wavelab to rescan plug-ins, it sees FG-X! But won’t allow it to be seen in the program!!!

This is all with the latest PACE / iLOK drivers etc.

If only Wavelab would allow me to set more than one VST plug-in path (like Cubase) then maybe I’d have a chance!!!

That’s odd…I installed FG-X 32 bit version in it’s very own folder and WL sees it + all other vst-plugin’s no problem :unamused:
When I open WL it scans automatically for new plugins, at least mine does.