Wavelab API ActiveX problem (Automation Server Can't Create

I’m trying to create a script for a specific batch job I want to perform to a set of files.

I’m using this line of code to instanciate a Wavelab Application:

var wavelab = new ActiveXObject("WaveLab8_5_64.Application");

But WSH returns “Automation Server Can’t Create Object”.

I did not found any WaveLab* ActiveXes register in my COM browser, so I’m guessing that wavelab installation failed to register them.

I’m NOT interested in reinstalling the product (Didn’t work). Does anybody know which DLL should I register ??? I tried WaveLab8_5_64.exe and Wavelab.tlb in the /Tools/Window Scripting but no luck.


Can’t you find this in the registry?

Did you try this script?..
C:\Program Files\Steinberg\WaveLab 8.5\Tools\Windows Scripting\Mp3-64.vbs

Hi Philippe, and thanks for the reply.

  1. Yes HKEY_CLASSES_ROOT\WaveLab8_5_64.Application is present in my registry…

  2. Yes I forgot to mention that I ran Hello-64.vbs and got the same message.



To whom it may concern:

The problem was that there was no entry in the HKEY_CLASSES_ROOT\CLSID for the ActiveX Control (Should be a UUID referenced by HKEY_CLASSES_ROOT\WaveLab8_5_64.Application, containing the AX registration information).

I tried reinstalling but this time this is what I did:

  1. I extracted all files from the downloadable exe to a folder.
  2. Quit the installer
  3. Ran Setup64.exe from the extracted folder as Administrator.

regedit showed that the ActiveX was registered correctly and the Hello-64.exe worked fine …

Kind Regards.

If it’s any help, I can run Hello-64.vbs without any problems (WL8.5x64 on W7x64). Do you have only the 64-bit WaveLab 8.5 installed, or do you have both the 64-bit and 32-bit versions of the application?