Wavelab Cast craches on video import

When I try to import a video in WaveLab Cast it crashes. I tried with different file types (.mov, .mp4), different files sizes, but have no luck with making it work so far. Am I missing something? Do I need to install anything else? Or follow some special workflow?

I am using win 10, 64-bit OS, x64 based processor, 16Gb RAM.

Any hints, suggestions?

What procedure do you take? Drag and drop the video file onto a video track?

No I was actually using the procedure described in the user manual:

  1. Select File > Import > Video.
  2. Select the video file that you want to import and click Import (Wavelab asks me to select a template to use, even though I already have an audio montage created. I select Host + Video)

As result I should have the imported video file is displayed as a clip on the video track. Instead, I am just kicked out of Wavelab. No errors. Just crash.

I just tried to drag and drop the video in the Clip/Video window after creating an audio montage. It worked for MOV file, but not for mp4 - I am getting “The format is unknown or Wavelab could not find a suitable decoder on your system”


I was getting crashed too, using a .MOV file, seems I had to choose the 'podcast + video 48kHz template in order to get the file to import correclty.