WaveLab constantly crashes - /Library/Preferences/WaveLab 7


Since yesterday my WaveLab has become impossible to use.
At startup it says: ‘‘An error has occured. The file could not be written successfully.’’
Then, it crashes whenever I try to do anything.
When I try to switch it off, it crashes also and says: ''An error occurred. The directory could not be created. ‘/Library/Preferences/WaveLab 7/Cache/Window Config’ ‘’

I am on Mac Lion 10.7.2
It happened with my WaveLab 7.1, so I tried to update to ant it is the same story.
The weird thing is there is no such folder /Library/Preferences/WaveLab 7

Could someone help me here ? I really don’t know what to do and I’m stuck.
This is really annoying.


Try erasing manually the whole folder
Library/Preferences/WaveLab 7/Cache/


Hi Philippe,
Thanks a lot for your quick answer.
The thing is I don’t have any folder called ‘‘WaveLab 7’’ in /Library/Preferences/.
This maybe my issue. It’s the Library at the root of my hard drive, right ?

The exact path should be:
/Users/YourName/Library/Preferences/WaveLab 7/Cache

Hey Philippe,
Thanks again.
I definitely don’t have any folder called ‘‘Library’’ in /Users/Myname
Timemachine tells me I never had any.
I have a folder Library at the root of my hard drive though, but no WaveLab folder in it.

WaveLab 7 has been working great for several weeks, and I had some preferences stored (colors of waves and so on).
I am running Mac OSX 10.7.2 Lion
Thanks for your help.

In which language do you run? If not english, look for the translation of “Library”.
You could also do a file search with the finder, for WaveLab 7

My Mac is in English and where I enter WaveLab in Spotlight, I see only the application.

I tried to re-install WaveLab and it is exactly the same behavior. It says ‘‘An error has occured. The file could not be written successfully.’’
Then it is impossible to switch the soundcard, or play a sound. It just crashes.
And I still don’t have any folder called ‘‘Library’’ in my /Users/myname/
This is really annoying… I don’t know what to do now…
Thanks for your help.

Isn’t the Library hidden in Mac Lion 10.2? Maybe you can try a Google search and see if that comes up with a result to make it visible.

Luck, Arjan

Thanks Arjan P, you are totally right. The folder /Users/myname/Library is hidden by default in Lion and one should enter the command ‘’ chflags nohidden ~/Library/ ‘’ in the Terminal to display it.
So that’s what I did. I can see the folder /Users/myname/Library/Preferences/WaveLab 7/cache
I deleted it. It seems it is better and I can use WaveLab now. But I still have the message ‘‘An error has occured’’ when opening it, and there is no way to save my preferences (like changing the display settings).
Also when quitting WaveLab 7, Lion tells me ‘‘WaveLab 7 quit unexpectedly’’.
And when I re-open it my setting are not saved.

Then erase the whole
/Users/myname/Library/Preferences/WaveLab 7/
not only the Cache folder.

Thanks a lot it finally worked out erasing the whole folder WaveLab 7 in /Users/myname/Library/Preferences/
I am glad it works now. Back to work !
Merry Christmas

I also had the trouble as the same. One more thing, I am difficultly to find the wavelab 7/cache on my Mac version 10.7.4. I already did which you said above, but it’s not see any things.


Try with EasyFind or Find Any File app

regards S-EH