Wavelab Elements on Macbook Air M1 running Big Sur not working

Wavelab Elements on Macbook Air with M1 running Big Sur 11.3.1 not working. The program is using the Rosetta 2 but is extremely sluggish. Pinwheels every few minutes. Playing back a simple .wav file the default meters are glitchy and do not show smoothly. Also Elements is larger than the screen size of the 13" and the Play/Stop buttons are below the Dock.

I previously had a 2015 Macbook Pro 15" intel i7 using Mojave but the computer died and had to get a new one. I had no problems at all with Elements on that setup. Everything normal.

Look forward to a Universal Build for Apple M1 silicon. As of now Elements is unusable for Me.

I’ve got Ableton Live 10 and that is playing back fine.

Did you install a fresh WaveLab installation (without reusing older settings) ?

1 Like

Hi PG. No I did not do a fresh install. I had the latest Wavelab Elements update installed already. My old computer died and I restored from a time machine backup to the new M1 Air. All i tried was playing back a .wav file and it played the song but the meters were glitchy and pin wheel occurs a lot. The mouse pin wheels every few seconds during playback and there’s a delay in the graphics. How do you install a fresh WaveLab installation (without reusing older settings) ? What does that have to do with the playback problem? Thanks

You could simply try to erase the preference folder:
/Users/YourName/Library/Preferences/WaveLab Elements 10.0/

1 Like

ok, its working! I deleted the old application and the preference folder. Downloaded the latest full installer. It rescanned all my plugins on open. The playback of the song .wav file was normal and smooth. The meters working again without glitches. Also, the screen is properly sized and the transport controls are no longer under the dock. Thank you.

After reinstallation, I figured out that I previously had the Izotope Ozone 6 plugin on the master section. When I removed that plugin, playback occurred normally. This Ozone 6 plugin is not operating correctly on this system and is the cause of the graphic playback problem. I also tried the Ozone 6 plugin in Ableton Live and it does the same to the graphics and glitches Live. Thanks for your help.

Thanks for this thread, as the same thing happened to me. Yesterday it worked fine, today it crashed on every file that I tried to open. I followed your steps and it’s working again. Whoa!