WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

I’m attempting to use / run WaveLab Elements 10 on a 2018 MacBook Pro w/ Touch Bar (Core i7 / Radeon Pro 555x / 16GB / 512GB SSD) and fresh install of macOS Mojave with updates installed (currently at 10.14.6)

I have a CalDigit USB-C Pro Dock connected via (an Apple 0.7m) Thunderbolt 3 Cable and also use an RME BabyFace Pro (with latest drivers) installed and connected to the dock via USB.

I tried the initial WaveLab Elements 10 install and also the 10.0.5 incremental update. I can get a new workspace to open, but whenever I try to open Preferences, the program just Force Quits / Crashes. I’ve tried with CalDigit dock connected and without the dock & interface connected (just on Battery power with no peripherals connected.) I’ve deleted the user preferences (under user/Library/Preferences/WaveLab Elements 10.0) with both the dock connected and while running on battery (again, without any additional peripherals connected.) Both versions for macOS are exhibiting the same behavior regardless of what I’ve tried.

Additionally, I’ve confirmed the (Software) eLicenser shows the correct license for this version.

Curious if anyone else is experiencing this issue and/or if there is a fix or possibly something I may have not tried as-of yet that may be causing this issue.

I can upload crash logs of both scenarios if necessary.

Please upload crash in PM. Thanks

Done. Please see PM’s. Thank you

If you have the possibility, move your eLicenser to a Steinberg dongle.

Hey PG - at this time, I don’t own a Steinberg eLicenser dongle. Is this something that stood-out in the crash logs?

Yes, we have a mysterious case that happens only an WaveLab Elements and in specific scenario and only on some machines (and the crash log shows this case). So far using a physical dongle cured the problem each time. This being said, we could have a solution for 10.0.10, if you can wait.

How long do you expect before the 10.0.10 release is out? Also, would it be possible to have a license re-issued for 9.5 so I have something to work with in the interim? Thanks for your assistance.

You can use WaveLab Elements 9.5 with the WaveLab 10 license. But the problem might happen in 9.5 too.
10.0.10 should happen in november, but not before mid.

Well, gave WaveLab Elements v9.5.50.208 a shot and was actually able to click-on Preferences, but crashed soon there-after (like you said would happen.) This really stinks. I tested on my PC (Lenovo X1 Carbon 6th Gen / Core i7-8550U / 16GB / 512GB SSD) and had no issues what-so-ever (and that was an in-place upgrade.) Guess it’s a sit and wait game, since I really hate to spend the money on eLicenser dongle I will never use again once this is resolved.

Also you have to realize that once you move the license to the eLicenser dongle, there is no way to move it back to the soft eLicenser…

Thanks for clarifying that Arjan. Even more reason to just hold-out for the 10.0.10 update at this time.

Thank you for this very clear feedback
I’ll wait for 10.0.10
For sure the same solution will be needed for WE 9.5.50 which crash same way on Audio Connection tab
Regards

PG - Are you seeing this same issue happening in WaveLab Pro 10 as well?

Are you seeing this same issue happening in WaveLab Pro 10 as well?

No. The crash when going to the preferences, is only on WaveLab Elements, and only on certain machines.

Thanks for the quick reply PG - Was formerly an all PC / Windows 10 user but I’m doing more work on the macOS side recently and was considering purchasing WaveLab Pro, thus my asking.

I’m having a crash that is very similar to this, most often when using the ‘Audio Files’ tab in preferences. I’m on High Sierra though. Is it likely to be the same issue?

Wondering how much longer for this 10.0.10 update that’s supposed to alleviate this issue? It’s almost the end-of-month and still no update.

Part of the WaveLab elements issue is solved with the latest elicenser version.

I have the latest eLicenser. When I click on “Preferences” > “Audio Files” WaveLab Elements 10 crashes every time so, it’s not fully resolved.

Intersting. I was having that issue on my laptop (with Catalina installed), but the new eLicenser update solved it.

I wonder if some additional preference files need to be trashed as well.