WaveLab Elements 7 and LAME MP3 encoder

I am running WaveLab Elements 7 successfully again after a HDD crash/re-format.

In the past, I used the LAME .DLL - just put it in the System folder, and it worked for Saving/Rendering WAV files.

I have put the “lame_enc.dll” file in the System folder, but the options for Saving in WaveLab do not allow constant bit rate, and error messages occur when saving the file; the rendered MP3 is not playable. Obviously, something is wrong.

Note that I installed version 7.2.1 from the patch only - I never used the CD for a re-install, since the original 7.0 version is actually 32-bit.

In any case, this approach worked before, but is not working now. I also noticed that the support page in Steinberg gives incorrect information about Program file folders:
It is the 32-bit systems that use "Program Files(x86)\Steinberg\WaveLab Elements 7\System " - not the 64-bit OS.

Any thoughts? Thanks!

I guess you have a wrong version of the lame encoder DLL.

It’s the same version that I used before - I also tried the latest .DLL from LAME (2013 version).

Any thoughts as to why this is not working now?

Here is the error message:

Problem has been solved!

The issue was using a non-64 bit DLL; Apparently, I was using a 32-bit version in the 32 bit Windows folder before.


I downloaded the LAME encoder myself today (version 3.99.5 64 Bit) and placed it in the folder C:\Program Files\Steinberg\WaveLab LE 8\System. Yet when I’m in WL Elements 8 I don’t even see the option for rendering to mp3, just the standard options for WAV, FLAC, OGG and WMA. Have I forgotten to do something?

ok, it seems I mistook the presets for being all the available options. When I clicked on Edit I was able to see the Audio File Format dialog with the LAME encoder available in the dropdown list. Strangely enough, when I previously copied the Fraunhofer encoder (which I bought for use in Cubase) to the System directory, it didn’t show up in WL. Does Steinberg expect you to buy it once per program you use?

I have the same issue with Fraunhofer mp3 encoder. I bought it and can use it on Cubase 7.5 but I can’t get WL to encode to mp3. I can choose mp3 in the Save As… but then when I click to save it just goes to .WAV. Any ideas anyone?