Wavelab Elements 8 cant access Options/Vst Audio Connections

For what ever reason the program just locks up when trying to access the audio card options

Windows 10 anniv edition
MBox 2
Wavelab Elements 8

please help, feeling like i wasted my money as i havent been able to use it for sometime now

Just noticed it was the 32bit version, as well as outdated version…downloading latest version so let me see if this gets me back on track

no go, just updated to 9 (64bit) in hopes that it would fix the issue, but i still cannot access the audio connections menu…im at a lost

Audio interface works for all other programs


just tried with mbox2 unplugged and still no good

This could be an ASIO driver issue.

Look in the registry at this key:

WaveLab will try to load these drivers.
You could try to temporarily remove these keys to see if that changes something.
One solution is to erase the CLSID variable.
Later, whether you paste the values again, to restore the info. You could also reinstall the drivers.

Wow, It seems none of my replies posted yesterday evening.

PG, it was the long list of old asio drivers in the registry that caused the issue. Had about 15 of which only 4 are legit.

Wave-lab now working, thanks!