Wavelab LE ate my audio file!

Using a macbook pro running OS 10.8.5 and Wavelab LE.

Transferred an mp3 file from my Yamaha PR-7. I was adding markers and editing the file. Went to save it, and it would not save no matter what name I gave the file. The program would not quit either.
The program asked if I wanted to create a backup of the file so I ticked yes. Then I quit without saving, assuming I at least had the original file on my desktop.
The program quit. I no longer had my original mp3. All that remained was an exec file with a “.bak” suffix.
No application will open it.
Has anyone else experienced this? Can I recover my audio file? It was an amazing live performance that I captured.
Is it gone forever?

Thanks in advance.

Make a safety copy of the file (copy/paste or option_drag), and remove .bak from the file name. If it asks you if you want to add .mp3 extension, answer “add”. No guarantee, but it should work.
Also there’s a thread about the issues of MP3 editing, since it usually involves double encoding I would think:

Bob99 you are awesome!

That worked like a charm. I thought that audio file was gone for good.

Thank you for sharing your knowledge.

Gotta make sure that doesn’t happen again.

Thanks again.


Glad it worked. You might want to try one of the utilities mentioned in the thread, or mp3TrueEdit
http://download.cnet.com/Mp3TrueEdit/3000-2170_4-75629371.html to keep the quality without re-encoding to MP3.

Sorry, forgot you were on Mac: