Wavelab LE won't install on Windows 7 - 64 bit

Hi all.

I have a PC with Windows 7 - 64 bit as the operating system. When I purchased a Zoom H1 recorder, I got instructions on downloading WaveLab LE.

I downloaded the software. It downloads as: wavelab_le_win_8.0.3.698.

But when I try to install it, Windows 7 tries to open it, and I get a message saying “Windows can’t open this file.”

I tried using the Windows 7 “run” command, but got the same result.

Can anyone help me?


Many years ago, when computer games first came out, there was a stupid game called: Leisure Suit Larry in the Land of the Lounge Lizards. At one point in the game he is looking for a lost ticket that will get him on a cruise ship. He comes to a trash can in the alley. You type the commands into the program, so you type, “Look in the trash can.” The reply comes back, “It’s not there.” But if you persist, and say “Look in the trash can” again and again, on the third time, you find the ticket.

So, the third time I downloaded the program, it finally downloaded with an “exe” extension. And yes, it installed.