WaveLab Pro 10 Possible AAC Crash Error - Can't Be Certain


In the last few days, I have been converting AIF files to AAC in WaveLab without any issues - until now.

The file(s) I am converting are AIF located in my Downloads folder and I was successfully able to select that folder using the recent folder list at the top of the Open File dialog. To the right of that list, AAC is the currently selected option as it was the last format I used to convert the AIF.

Now, with that configuration in place, as soon as I select the recent Downloads folder from the list, WaveLab immediately crashes out. If I change the last used format to AIF and then select the Downloads folder from the recents list, it behaves normally and the file opens correctly. However, as soon as I choose to save and select AAC as the format, WaveLab crashes out again.

The confusing thing is that WaveLab was happily navigating to and from the folders with the formats selected and saving out without any issues. Suddenly it has just started crashing out and I can’t figure out what might be causing the problem. At this stage, it appears to be linked to the AAC format. I have tried removing caches and preferences to rebuild everything, to no avail. The problem still happens. Opening the file only appears to work if I change the recent format to something other than AAC. But it still crashes if I choose to save to AAC.

I have saved a crash report if anyone from the development team needs to look at it.

I’d appreciate your thoughts.


Please send a crash log

Hi Philippe,

Crash Log attached.

WaveLab Crash Report.txt.zip (24.6 KB)

Unfortunately, the log does not give much info.
Does it happen with any AAC file, or only certain files?

Murphy’s Law that I can’t replicate it again now - which is why I said I wasn’t certain about the cause of this. Now it’s behaving again as it was originally, without issue.

I certainly don’t mean to waste your time so I’ll keep monitoring it to see if it occurs again.

To answer your question though, it appeared to be connected to the AAC ‘format’ and not necessarily an AAC file. As long as the AAC option was at the top of the list as the last used option, it crashed out as soon as I tried to select a recent folder. If I changed the last used option to AIF and then selected the folder, there was no problem. That’s why I thought it was linked to the AAC format somehow.

But with it behaving again, I’m willing to concede that it could be on my system. I’m just sure what could have caused it because the workflow procedure didn’t change and nothing was added or removed throughout.

I’ll keep an eye on it and post again if I run into the same problem. Thank you for responding.

Murphy’s Law that I can’t replicate it again now

Well, sometimes I like Murphy :wink:

The crash said at least: happens while trying to decode an AAC file.

Hi again Philippe,

OK - now the problem is a whole lot worse. I can’t even get beyond ‘File > Open’ and WaveLab just crashes out. So now I can’t open any file at all!

I managed to drag and drop a FLAC file onto the blank workspace and it opened happily, but trying to execute a File > Open now simply crashes the app out.

I have attached the most recent crash log as it happened. Sadly I have no idea what’s in it so I’ll have to ask you to take a look through it and see if it’s any different to the first one I sent.

I have been working the system a bit with video conversions, 5.1 surround downmixes out of Cubase - after which I was using WaveLab to convert to AAC. So I honestly don’t know if something has just got in the way or whatever. But these crashes are totally new and unexpected. The app has been rock solid up until now.

Hope you can perhaps shed some light on it. Murphy’s come back to haunt you :confused:

Many thanks
WaveLab Crash - New.txt.zip (24.2 KB)

Maybe there is a “dirty” file that causes this, and this happens when WaveLab’s file browser is evaluating the files in a given directory.
Try to locate and delete the file. Or try to locate and send me this file. I can only find a solution if I have a sample file at my disposal.

Yes, I think your explanation is more than likely the correct diagnosis. I can’t imagine it’s a WaveLab inherent issue as it’s intermittent and certainly wasn’t happening before. The only file types that would exist in the folder by the time I get to the AAC conversion step are video only MP4, FLAC (5.1 surround) and AIF stereo downmix from Cubase.

I will try a process of elimination if it occurs again to establish what might be causing the issue.

It appears to be the MP4 video only file that is causing the issue. While the file is present, WaveLab crashes out. I moved it to another location, problem solved!

Naturally I have no idea about the complexities or technicalities of that, but clearly I can’t have the video MP4 file in the same folder as the audio files I want WaveLab to work with. Just for your info, the MP4 file is rendered via FFMPEG as h264 video only.

Interesting issue, but at least I know what’s causing the problem.

If there is a chance (file not too big), please give me a link to that file.

The file is too large to try and get to you effectively - 2.31GB

For now, I’ve attached Mediainfo analyses of the file in both txt and JSON formats, if it helps at all. If I can get you any other info please let me know. I have various tools I can use to probe the data.
MP4 Mediainfo Reports.zip (2.99 KB)