Waves and vst plugins not loading on channel

i upgraded from win 7 tp win 10 , my plugins are visible in cubase list but when i select them for track they wont load, i have the latest waves and vst plugins versions, runing on cubase 11, i tried an old cubase version an that also did not work , my plugins work on wavelab elements… any ideas?

Did you also switch from 32bit Windows to 64bit Windows?

hello … thank you for the replay … i switch from 7pro 64 bit… everything worked before … the vst instruments work and my UAD plugins and vst plugins dont load in channel , funny thing is theu work on Wavelab

Sounds strange indeed - I’ve also done a Win7 (x64) to Win10 (x64) migration, but it was quite a few years ago, so my memory on what I did is very fuzzy. I don’t have any UAD, but was able to get my Waves stuff working.

Have you also tried to check your plugins in the VST Plugin Manager? That’s the place where you can really tell if Cubase sees them or not.

i have looked in the manager, they are all there , i am stumped … i am sure it it a simple fix , but hard to find …

vst2 or vst3 ?

did you just do a reinstall of the waves software - it might not have survived the update

i had wave 9 and upgraded to 12 after the upgrade , i thought that may fix it but it did not … they do work in wavelab

I’d uninstall / reinstall - waves is a bit fussy :slight_smile:

thanks … i tried re-installing waves and cubase , but still the same issue

Have you tried to hunt down possible solutions on the Waves forums yet?

And I’m really not sure, if it has to do with what you’re seeing - but if Waves works in WaveLab, but not Cubase - is there any chance that you are running one as Administrator and the other one is not running as Administrator?

I have windows 10 64 bit, and I have to repair the waves plugins every single time I clean my PC.
Open waves central, go to settings and click REPAIR. Maybe this will work…
Go in Cubase to vst plugin manager and see if the plugins are blocklisted.
When we update system sometimes there are licence issues. Let’s say if you have plugins that use iLOk for example, you have to check if the licences are there. Check also that the plugins are in the correct folders where Cubase looks for them, if the path is correct, in Vst plugin manager.

I’m curious as to how (why?) you ‘clean’ your PC (off topic)

I didn’t mean water and soap :grin:
the cleaning of PC is a routine activity which is suggested by many, in order to speed the system, it removes unnecessary files and previous windows installation files, a clean pc with less data on the HD goes faster. I select windows C, right click, properties, disk clean up, if you want the cleaning be stronger, select clean up system files. Till here is fine, the problems start if I use a third party cleaning software (as c cleaner or similar) to get a deeper and more effective cleaning . Only the waves plugins have problems, I have i zotope, Softube, toontrack…many other plugins…any problem with them

lots of myths around the internet :slight_smile: and totally off topic for me to comment here although I will say this:

if you are using third party software that is removing authorisations or interfering with legitimate software then you have to ask if it’s something that you want to do…just sayin’


1 Like

well strangelove, sometimes we can get good advices also off topic :+1:
you are perfectly right, sometimes we perform routine “absurdities” without even realizing it, and we need someone’s else to break the cycle, this is the purpose of a forum. Anyway the fact that only waves plugins had problem seemed to me relevant for this discussion thread, where another user reports problems with Waves

1 Like

If you updated to Waves V12 plugins and now they don’t show / or don’t open in your DAW, here’s the solution:

Apparently, a recent Windows update and the Waves V12 plugins don’t get along so easily. It has something to do with the Microsoft C++ Redistributables. (They have different versions: 2005, 2008, 2010, etc.) After 4 hours of looking for a solution, I found that downloading a package of all the MS C++ Redistributables, and installing all of them, is solving the issue.

You could also download them directly from Microsoft (one at a time) but I think installing all of them at once is quicker and easier. I got mine from the techspot website. After installing, I opened Cubase and loaded the API 2500. The GUI is showing up and it works as expected again. :slight_smile:

1 Like