Waves Audio Track causes issues - Audio not saving

I have been using Waves Audio Track on every channel.
I also use the L1 + Ultramaximizer on my stereo out.

After using Cubasis for a while, and there is no repeatable rhyme or reason when it happens - if I hit stop on a recording, the app will flash like it is saving, but there will be no audio file.

Very strange because sometimes it will save, and other times it won’t.

I have tried everything I can think of to make it stop doing this, to no avail.

When I stop using the waves effects, everything works fine.

Are there compatibility issues with ios 12 and waves effects perhaps.

Anyone else having the same or similar issues with an audio track just disappeaing?

It is frustrating to be recording for a long while and then lose what you were recording.

Ios12 on an ipad pro 12.9 generation 2. Latest version of cubasis.

Can’t think of any solutions other than to stop using waves.

Hi Dillon99999,

If possible, please provide us with the project alongside the steps to reproduce the issue.
Please upload the project via Dropbox and share the link via private message.


There seems to be a few Audio issues popping up.
I find FM player missing notes when freeze.
Korg M1 not playing correct when freeze
Even Audio layer missing track when mixed down to a wav file…
Un armed & un monitored track plays along with next track while recording.
I have to select all midi out to hear inter app midi once recorded or theres no sound…

Since removing waves effects on the channels and the stereo out, cubasis is working just fine.

I also tried using 44.1 24 bit and that helped me get a little further along - 7 stereo tracks before it started doing it again.

Before doing so, it would barely get past 2 stereo tracks using 48 24 bit. I am recording whole albums of music - very long 1 hour stereo tracks to archive some of my favorite albums into cubase. This originally started out as a test to see what waves could do to polish up some old music.

My latency is ultra low with large record buffer. Never had an issue until I started using these effects.

I think there is some sort of dithering or precision issue with it. But that is just my best gues based on what I have expierienced so far.

This indicates it is a waves issue. But because it is an in app purchase, i suspect that finding help will be like getting to the moon.

Hi all,

Please don’t let us mix topics here, Cubasis99999.
Instead please create a separate topic to have your issue addressed.


Hi Dillon99999,

Thanks for your message.

As mentioned above, please provide me with the project and exact steps required to reproduce the problem, to allow our developers to evaluate the issue. Once available and reproducible, there is a good chance to address the bug.