Waves GUI grabs control...

I notice a weird issue with C6.04 and my (admittedly very old) Waves 5.9.7 plugs…

If any Waves window is selected, I lose keyboard commands to Cubase - all of them - start, stop, everything. I don’t remember noticing this with earlier C6 versions - can anyone confirm? And does it happen with more recent Waves versions?

I don’t have Waves plug-ins but Jamstix does the same thing. When it has “focus” I can’t start/stop with the space bar or use any transport commands (haven’t tried other key commands but assuming the same result.) I have to first click somewhere in the Cubase window for it to be the target of the keyboard.

Thanks for that. Interesting that it affects Windows as well as Mac.

It doesn’t seem to affect other plugs - UAD for example.

There used to be (years ago) a problem with this issue affecting all plug-ins and Steinberg provided a Pref something like “Disable key commands to plug-ins” but I don’t think it’s there any more.

Neither, as far as I know, is there any Waves preference to disable key commands.

I am sure it is in the programming of the plug-in. Jamstix can actually use some key commands, therefore needs to be able to receive them. Some plug-ins have no use for them, or just aren’t programmed to use any, and therefore are not programmed to recieve them. My educated guess is that when the developer writes the code for the plug-in, there is some attribute that they set called something like “can_have_key_command_focus=1” (or set to =0) that determines how it behaves.

Yes, that may well be - but Waves doesn’t use KCs (AFAIK) and some other plugs which do (UAD) aren’t affected…

Im using v 7 & 8 waves plugs, no issue here.
I think updating is your fix.

Or ditching Waves.

I have a license for Waves Gold hanging around here. Nothing in that bundle that hasn’t been utterly surpassed by the standard Cubase plugins.