Waves Nx effect plug-in

I downloaded the Waves Nx plug-in for mixing over headphones. It works in Cubase 8 Elements but I have been unable to get it working in Dorico. Although I am able to load the plugin name into the top insert slot of Dorico’s output channel, clicking on the small “e” button above the plugin name fails to bring up the plugin window. Also, using the small icon next to it should turn the plugin on and off but this makes no audible effect, unlike the clearly audible effect in Cubase. The format of the plugin (VST2 or 3, AU) is not identified on Waves’ web page and, in any event, I am unclear whether effects plugins need to be in VST3 format unless added to the “white list” just like virtual instruments. I am using a MacBook Air and OS X 10.10.5 Yosemite. Any suggestions?

Effects plug-ins do indeed need to be whitelisted if they are going to appear in Dorico’s mixer window. But if the name of the plug-in appears in the list of effects plug-ins, I think that indicates it’s been loaded by Dorico without problems. I believe the bypass buttons in the Mixer are not yet implemented. However, when you click the ‘e’ button to show the plug-in’s editor it should appear. I’m not sure what else to suggest, unfortunately. Perhaps Ulf or Paul might have some ideas – I will ask them.

I encountered the phenomen that you can have 32 bi vst2m 32 bit vst3, 62 bit vst 2.x , vst 3 64 bit and then 3 of the 4 get blacklisteded, yes it can :wink:

Man o man, it’s happy new year and my promilage is over the top :laughing: :mrgreen: :blush:

:mrgreen: BTW it is 4.51 AM int the Netherlands :mrgreen:

Thanks and Happy New Year, Menoj! Here in western Canada it is still only 11:47 pm on December 31st but I will be celebrating very soon.

Hi Mike,

sorry for being late on this. True, we have an issue here. I just got a demo version of NX and tried on my MacMini with Sierra on it, and same result: The plug-in apparently gets loaded into the insert slot, but no UI.

So I’ve tracked this in our database and we’ll work on it, please be patient.


Small update: Actually, Dorico just pretends that the NX plug-in got loaded where in fact it didn’t. The log of the audio engine shows that it tries to load the plug but then somehow fails for reasons still not known, yet. So there is no use for you in further trying it.

But as said, we are working on it.

I already left a thank you using the thumbs up icon but think that you, Daniel, and Paul (who are most heard on this forum) and other members of the Dorico team working behind the scenes deserve more - you guys are the best!

By the way, this is fixed in the upcoming 1.0.30 release, which we expect to come out next week.

I’m impressed that you came back to let me know. Thanks, Ulf!