Waves V11 Update

Hey community. Question regarding Wave v11. I was wondering if I could update my waves plugins to v11 even though I have Cubase 9.5 (latest update). I read on the waves site that only Cubase 10 was an approved support host (https://www.waves.com/support/tech-specs/supported-hosts). I hope this is a mistake because i’d like to capitalize on this update.

Thanks in advance

Hi,

That would be probably question for Waves… I would say it’s true, when it’s written there.

I just upgraded this week without any issues. I have Cubase 9.5 latest update.

Wave V11 plugins working here in both C9.5 and C10.0.50 and everything else I have.