Waves v13 Plugins not showing in Cubase 12

Have Cubase 12 Pro, none of my wave plugs are showing up in cubase or even scanning. The vst3 is working in studio one fine and au in logic. Any help would be greatly appreciated.


But they are working for others as far as my research says

Yeah mine are all working. I use the SSL and API plugs in every project… Intel Mac running Monterey here.

I don’t have any waves V13 here, but versions 12, 10 and 9 are running fine in Cubase 12 pro.

EDIT: Windows 10 Pro 21H2

I’ve been at it all day trying to fix it. Mines a Mac mini m1. I’ve installed waves about 20 times and deleted cubase cache about the same. It actually scans them but nothing shows in the DAW

Disaster actually

From my experience this is not a Cubase issue. It can happen with waves plugins v13 in other DAWs too.

The following solution worked for me in this case: Open Waves Central an then execute REPAIR all. Then rescan in Cubase. (I don’t have my computer here so can’t say where exactly you find that option in waves central.)

Hope it helps, Cheers

1 Like

Are WAVES compatible NATIVELY with M1’s or are you supposed to be using ROSETTA to run things WAVE right now??

My research says. WAVES 13 is NOT listed as compatible from their chart with Cubase 12, however you should simply ask WAVES as they are very helpful as long as you have your WUP going. This does not mean they won’t work as the chart may or may not be up to date. I am running WAVES 13 on Cubase 11 here with Monterey so not the same as you there.

VST 2 is DROPPED in Cubase 12 when running M1 NATIVELY if you are not aware.

Windows users posting all is well will not help you on your Mac.

I`m on windows and none of my waves plugins are available in Cubase 12 pro. so clearly something is wrong and waves plugins are not compatible at the moment.
I went back to Cubase 11 and waves were there and avaliable.
maybe its a windows issue, I have no idea.
if anyone on windows 10 and running Cubase 12 has all there waves avaliable could you let us know how you did it

I’m running Windows 10 pro, with Cubase 11 pro updated. I’m mid-way through 2 albums, I currently built a brand new system and in the process of transferring everything over. My old system seems to see all the available plug-ins and sessions perfectly, but my new system sees everything working fine except for the waves plug-ins. Not sure what’s going on.

I’ve tried installing Waves v13 and v12 offline, but Waves keeps forcing the v14 on me. Very frustrating. I have Waves v14 on the old system and Cubase sees it just fine, although, Cubase 11 pro hasn’t been updated on my old system.

Is there a way to revert back to an older version of Cubase 11 pro before the update? I’m thinking it might solve my issue.

I know this is an old post, but I was recently trying to get my Waves v9.3 plugins working with Cubase. I was able to open GTR by itself, so it looked like the plugins were installed right, but Cubase would scan them and not load.

The post above that talked about “Repair” inspired me to run the Waves v9.3 installer again and click the “Repair” option in the installer. That worked, now they’re loading!

Hope this helps someone.

1 Like