WAVES V9 64-BIT (rev TWO) is out!

No ilok needed, 64 bit support.

IT WILL NOT WORK UNDER VISTA, ONLY WINDOWS7. SEE TECH SPECS.
http://www.waves.com

Yep, and they crash every time I try to use them in WL7. However in Cubase 6.51, they work flawlessly.

What system are you using?

Win7 64bit

Since Waves state in their compatibility table that WaveLab v7.2.1 is supported, perhaps they are the ones to be asked about this?

Paul

They work for me with Walelab 7.2.1x64 and W7x64.

I had it installed yesterday, but didn’t test it yet with Wavelab, on OSX.
Tomorrow I’ll try it and give you some feedback about it…

Oops! I was mistaken. Wavelab 64 scans and recognizes the Waves plugs on startup, just fine. But invoking any of them causes a serious crash. Must then use Task Manager to halt to process in order to complete the shutdown, as even the close command stops working. Like others, I’ve found the Wave 9 plugs to work in Cubase.

That’s exactly the same problem I’m experiencing.

Waves 9 doesn’t work with Wavelab 7 on OSX… :frowning:

Ok, I guess this will be fixed within the next days.

I haven’t tested it myself, but I know two persons that use Waves 9 with success (Mac and Win 64).

When I try to insert a Waves plug-in I also get the, “serious error has ocurred” message.

All was fine before the install of Waves version 9.

Win 7 64bit and Waves version 9 and Wavelab 7.2.1.

I wouldn’t be surprised to see a V9 revision 2 in a few days from Waves. :neutral_face:

I’ve had no problems at all like this with v9 on WL7 build 600, in either the 32-bit or 64-bit configuration.

I recommend Waves telephone tech support in this case. In my experience they’re very thorough, and usually get the problem resolved.


svs95

Try blocking the path to the WaveShell-VST 9.0.dll and / or WaveShell-VST 9.0_x64.dll in the WL7 Plugin Options - I’m using a path like this - C:\Program Files (x86)\Steinberg\VSTPlugins\Waves;C:\Program Files\Steinberg\VSTPlugins\Waves - so that only the Waves DLL is ignored. I had done this to reduce the clutter, but just tried putting them back and if I use a VST in the Master Section - boom! I can use either VST or VST3 in the Montage and either works fine.

This way WL7 only sees the VST3 versions which seem to work fine - not sure of the benefit of have both versions (back compatibility???) as it just clutters up the list in the Dithering Section on Master where you can’t tell which one is which - until you choose a VST and it blows up - then you know. :astonished:

I would make sure, before installing Version 9… you take the time to delete “ALL” prefs and waveshells associated with ver 8. Then repair permissions, and reboot… or whatever you Windows folks need to do also :wink: then do a fresh install of ver 9. I was reading on the Waves site, that VST2 is not supported or I guess coded in 64bit… so like the quoted text says… make sure you go and remove the VST2(VST) waveshell only leaving the VST3 one to use.

This should fix most cases.

No, the problem still persists, even when blocking the VST2 version. I’m in contact with Waves but they haven’t found a solution yet.

I am in contact with Waves support, too. Not solved, yet. I was assured I’m not the only one having this issue. I have some further instructions to follow.

It’s working!

Waves support identified a problem with an old video driver. I updated mine, and, behold, it worketh!