Waves v9r10 redundant plugins?

Hello,

I’m using Windows 8 64 bit with the Wavelab 7 32 bit version. I have been using Waves plugins for quite some time and everything has been working well. I recently updated the Waves plugins from v9r9 to the latest version v9r10 (released last week). Once the update was complete there were two versions of each waves plugin available in Wavelab 7. The update worked fine with Nuendo but Wavelab now shows each plugin 2 times.

I contacted Waves support and after the checked my computer remotely for about an hour, the problem could not be resolved. I tried uninstalling and reinstalling the Waves plugins, uninstalling and reinstalling Wavelab, removing the preferences for both programs but couldn’t solve the problem. Anyone else seeing redundant Waves plugins in Wavelab?

Thanks,

Peter

This is certainly because you see both VST-2 and VST-3 versions of the plugins. If you don’t need the VST-2 versions, remove them from your system.

No PG, same thing’s happening here, Tadpole’s right, there are doubled VST3 in Elements 64 as well (Win8). And of course VST2 (appear right). For sure it’s Waves’ fault. I tried any combination for VST folders, but… no way. :confused:

Waiting for WL8…

I have only 64 bit Waves plugins on my PC. A Waves plugin list appeared in the VST2 folder, and then there is a single list in the VST3 folder. I think that’s correct. So I just unchecked the list in the VST2 folder. Now I only have one list of the Waves plugins in the VST3. I just assumed this was a result of the WLE7 program. No big deal, just uncheck them.

Hi PG,

I have removed the VST-2 version of the Waveshell and this doesn’t make a difference. The double plugins occur with the VST-3 versions just like Markino said.

Each plugin appears as a double in the master section, clip effects, track effects and plugin organization window. The people at Waves support couldn’t figure out what was going on.

Peter

Then that could mean you have 2 versions of the WaveShell. Search your system for a redundant version of this file:
“WaveShell*”

Another idea: open with a text editor this file:
C:\Users[YourName]\AppData\Roaming\Steinberg\WaveLab 7\Cache\plugin-cache-*.txt

This lists all plugins found by WaveLab, as well as their file name. Have a look, that should give you the hint.

Hi PG, this is my folder, if you want and have time (I suppose you are very busy) I posted you both Cache files.

Thank you.
plugin-cache-3b3e862cd010f695b9b0bd13fc1728bb.txt (22.6 KB)
plugin-cache-04a4c2fbd9569e267f4c264f84653c97.txt (9.14 KB)
WLE cache.png

Hi PG,

I located the file that you suggested. I do see the doubled plugins in the list. I’m not sure how this helps. What do you suggest?

The Waves support people looked for extra versions of the Waveshell and nothing extra could be found.
plugin-cache-fd965c82171f59049f6463fcd8a1a268.txt (109 KB)

Just want to add that I am having the same issue. In the cache file mentioned there are duplicate entries for the plugins but I cannot find where there is a redundant Waveshell file.

The problem with the duplicates apart from anything else is having Mercury+SCC when I mouse over the VST3->Waves menu the opened menu fills the entire screen and doesn’t list all the plugins.

OK, I realize that I can remove the Waves plugins from the VST file, but in the VST3 file all the plugins are duplicated. Also, it doesn’t matter if I untick the duplicated plugin in the plugin organizer window, the duplicates show up.

The thing is, it didn’t behave like this before so I wonder who is to blame? The new V9 installer does NOT duplicate the Waves plugins in Cubase so Cubase must have something in place to prevent this. Inconvenient development, yes. :laughing:

@Markino
For 64 bit, you have 2 shells installed:
VST-2: C:\Program Files (x86)\VSTPlugIns\WaveShell-VST 9.2_x64.dll
VST-3: C:\Program Files\Common Files\VST3\WaveShell-VST3 9.2_x64.vst3

@tadpole
You have 2 shells installed:
VST-2: C:\Program Files (x86)\Steinberg\VstPlugins\Waves\WaveShell-VST 9.2.dll
VST-3: C:\Program Files (x86)\Common Files\VST3\WaveShell-VST3 9.2.vst3

You could simple rename the .dll version as .dl for WaveLab to ignore them.

The next question I have is how does this explain the duplicate readout in the WL VST3 folder? Does this mean the VST2 files are displaying in the VST3 window? If true, why?

Hello PG,
I have the same problem of double plugins. Nothing was wrong before V9.10 and now my VST3 menu is too big. I tried what you said but nothing’s change.
On Cubase 7 all is well and on Wavelab 7 there’s this problem.
Please found something.
Thanks

I have exactly the same problem with duplicate plugins on 9r10 in WL7 - was fine on 9r9 and is fine with Cubase 7 and PT10 :frowning:

OK, I tried this and it did not work.

Here’s the problem as it occurs: WL scans the Waves plugins, then the Sonnex, the the Steinberg. And we should be done… But then it scans the Waves plugins again. You can see this happen in the WL plugin scanning window as you load WL after telling it to rescan the plugins on next boot.

@ PG:

sorry PG, I tried what you kindly suggested, renamed both .dll as .dl, but VST3 shows the same problem.
Maybe I did not do the right steps…

Can the picture help?
Plug-ins Folder.png

Hi PG,

Thanks for trying to help with this. I have tried your suggestion of renaming the file but there were still double VST3 plugins in the list. I even tried removing the .dll file and the results were the same. This issue is not happening with Nuendo 6. I contacted Waves again by email. I’m hoping to hear back from them. Will report anything once I hear.

Thanks,

Peter

I have downloaded the Waves updates, and I can reproduce the problem. This is actually a Waves problem because the Waves Shell declares its plugins twice. This could be invisible in some application if the application checks for duplicates, but WaveLab 7 does not.
I see no solution for WaveLab 7 but reverting to Waves r9.

I will contact Waves.

Thanks for checking this out PG!

I just heard back from Wave support. Here’s what they said -

" I’ve checked the issue with our QA department and apparently this is a known issue that will be fixed in one of the upcoming versions. Unfortunately, at the moment there is no workaround for this."

thanks PG and tadpole - very helpful!