Wavetable Selector behaves strangely


I am not that kind of user, that shouts BUG everytime something isn´t working,
but after having a little talk and a file exchange with another user, it seems to be a bug…

For some strange reason the Wavetable Selector sometimes work, but generally
I cannot get a working Wavetable Select menu. Click in the Selector bar simply nothing happens,
except a flash on the borders of the Macro Page Editor Extended page.
Another user sent me an example, which does work, but rebuilding it by myself it doesn´t.
Also, when exported as VSTSound container, it doesn´t work either.

Anyone can confirm this? Or did I something wrong?
All the best.


NOTE: I am working on Windows 7 Pro, 8 MB RAM, using Xeon processor.

I have gathered additional information on this behaviour:

I found out, that editing a Macropage with the Wavetable Selector already inserted,
after a while the WT Selector simply stops working. Halion 6 makes this visible by not showing the Wavetable name anymore,
but simply inserting a ZERO in the WT Selector menu instead. I resolve this usually by deleting and re-inserting
the Wavetable Selector into the macropage.

To make it finally work, I have to play around with the SCOPE parameter of the WT Selector,
inserting a space or deleting one on applying @0:Zone1 .
Inserting a space before the 1 or deleting it makes the wavetables available again, sometimes after several tries.

Very strange. :confused:

Hi roger-s.,
you have created your own Wavetable set you want to select from, right?
Could you perhaps provide a lean HALion preset that will show the behaviour you described?

best regards
Gerrit Junge


Thanks for getting back and sorry for answering until now. I haven´t seen your message. Until now I solved this problem re-inserting the Wavetable selector, until it worked. At some random point it may (or may not) stop working. In my current project it did not occur again. If this behaviour returns, I´ll send you my project.

All the best.