WavLab 11 pro (11.0.30) freezes Windows 10 completely? :(

WavLab 11 pro (11.0.30) freezes Windows 10 completely??? :worried:
(Even control/alt/delete won’t work, only a “hard reset” gets things going again).

I’ve run into this strange behaviour of (WavLab?) by incident and it seems to occur only in a specific situation. I wonder if others can recreate this behaviour (is it a bug in WavLab?) or might there be another explanation?

The circumstances were under this happens are:

  1. From the Start “Hub” I choose “Project” (It seem to not happen when I choose “Montage”)
  2. Then I choose “Create Empty”
  3. Then I create a 16 bit 441.kHz Montage (it might happen also with other bit rates and/or sample frequencies but I’ve not tried that).
  4. I load a song into this montage.
  5. Then I insert the bx_digital v3 plugin* on the clip (it also happend when I inserted it on the track instead of the clip). * I first experienced it with a lot more plug-ins on that clip but then I tried each of them individually in this one seemed to couse the behaviour.
  6. Then (after some fiddling around with this plugin while playing the song) I choose to quite Wavlab without saving (so I unchecked the box in the warning popup) and choose “Exit WITHOUT saving” and click OK and then… WavLab closes (seemingly correctly) but after that my computer/Windows freeze and doesn’t respond at all (not even ctr/alt/del etc.). Only a hard reset can get it working again.

It seems to me that choosing “Project” at the start and “Quitting without Saving” (in combination with this particular plug-in (although it also happened with the SPL Iron plug-in [also from BrainWorx], but NOT with the Elysia Apha compressor, Tom Labs Lisa, Mäag EQ, Dangerous BaxEQ or other bx plug-ins) causes this strange behaviour.

And all the before mentioned plug-ins (I used them as VST 3) work fine in Cubase Pro 11 (11.0.41) and don’t cause any problem there.

So, what might be causing this problem? Can someone recreate it and confirm it?
Of course a workable solution is not to choose “Project” but “Audio Montage” instead when starting up WavLab, but as you get the option of “Create Empty” when choosing “Project” you shouldn’t run in to this kind of problems downsteam. But maybe it isn’t a WavLab problem at all end there is another explanation. Either way, I would like to find out.

I have a Windows Machine Windows 10 Home Version 21H2 Build 19044.1706,
WavLab 11 pro (11.0.30) and Cubase 11 pro (110.41) and SpectraLayers Pro 8.

FWIW, WaveLab 11.1 is out now and may it solve this:

Hi Justin, thanks for the hint.

I saw the announcement of the update just after I posted the issue. So I installed the update and just did a quick test (not very thoroughly) but it indeed seems that the issue has been fixed.
Although I can’t see any mentioned of it in the version history.

But as long as the issue doesn’t occur anymore (and I don’t have to “hard reset” my computer, which gives me anxiety) I’m happy.

Problem still exists… (also after the 11.1 update) :thinking:

Alas, I thought the problem was gone (with the 11.1 update) but it happened to me again today. Now even on opening by selecting Audio Montage and then create Empty. I had the KNIF Soma and the SPL Iron plug-ins on the clip (just trying something out) and then tried closing without saving. And alas Windows freezes completely again.

I also tried with the same audio file and the same plug-ins on the clip and then save the Montage and that went OK. So it seem to happen only ('till now) when not saving when quiting.

Could it be that there is something not completely fresh in managing the memory turnover when closing down between WL and Windows?

Never had this kind of problems before in WL Pro 11 and the same plug-ins work correctly in Cubase Pro (11.0.41)

I tried to generate a crash report but nothing is generated as WL seemingly closes correct. Although when I start WavLab after I had to hard reset my computer (because of the totally unresponsive Windows 10) I get a message that plug-in chain on the master section (mainly metering plug-ins couldn’t be loaded because it was/is damaged. Could this be an indication to what’s going wrong? As I know that normally the master section is saved automatically. Could it be that something is trying to write to memory and thereby causing Windows to freeze? Just thinking out loud.

I have had the Window “task manager” open to check if there are any unusual memory spikes or something that could point to some unusual behaviour, but there everything is quite normal and at the moment of shutting WL down everything freezes (as earlier said) even the Windows Task Manager. What could be the cause…?