Weird articulation bug, affected by ASIO buffer size

I have come across a bug where in some instruments there are notes that don’t sound under certain circumstances. The affected instruments I’ve found are “Real Pick Rock Bass”, “Real Fingered Modern Bass” and “Real Vintage Bass”. All of these have almost the same articulation scripts which involve legato detection.

The way you can reproduce the bug is to have a number of adjacent notes like in the attached image, and play them using any of the mentioned instruments. In some cases there will be skipped notes. The weird thing is that the bug happens much more when ASIO buffer size is bigger. Try 512 samples or 1024 and see. Of course this sequence is a way to force the bug but it can happen in a normal sequence, as it does to me.

My programming experience suggest that this bug may be produced by incorrect MIDI event alignment or execution within the same ASIO frame (had that bug in a sound driver I programmed recently), but of course I can’t know in Halion. Hope it helps a bit. Also, the bug happens when freezing the instrument (which suggest that it’s frozen using the same frame size than in real time).

That’s really interesting. I can confirm the behavior. I normally run with buffers at 288, so it didn’t show up.

I have always had this happen with notes that are too close or overlapping.
Nothing to do with articulations here. This happens with any VSTi.
I just figured it was the placement of the notes themselves.
I often have to go in and edit note release times to fix it.
If you have a midi insert on the channel, like the Quantize plugin doing a swing setting,
you might have to move the note release times even more.

Maybe this isn’t the same problem but your description fits my experiences perfectly.
Make sure your notes aren’t overlapping at all.
You should see space between the note release and the next note start…just a little.
That is what fixes it here.

This is a bit different, you can literally reduce the buffers and the problem goes away.

Rotund, I have no overlapping notes. I investigated the bug thoroughly before reporting, and of course the first thing I did when the problem arose was to check for overlapping notes. :slight_smile:

I only hope someone at Steinberg checks it and solves the problem…

This also affects chord tracks too. Very weird. I just never run with large buffers anymore, so haven’t run into this. But it is 100% reproducible.

Someone at Steinberg could please check this issue? thanks! :slight_smile:


Halion doesn’t render midi events in time properly. Tried playing a sequence in Halion with a buffer if 2 and 4 seconds and the events jitter. Kontakt didn’t jitter at all, and my own sampler engine didn’t either…

Something is not working right guys! just have a look at it please.

+1 confirmed

I wonder if this has any relation to the problem I experience. I have my buffers set at 512, which is the best for latency/performance, however, I constantly get playback and rendering errors of note expression data on my midi tracks. I use note expression for all my automation, be it volume, tuning, pitch and even for automation effects parameters and often times things won’t playback as I set them. If I have a tuning set to say +1 for a note, it will sometimes playback as -1, 0 etc. I can rewind and play again and it will playback as should, until I get to another part of my project that contains note expression data, only to have it playback wrong. It is extremely frustrating when you mixdown a 7 min project, only to hear one after another, all the times the rendering errors took place, causing me to have to bounce again and again and again, until it all dumped as planned.

I just found out that Retrologue has the same problem. If you create notes with very small length (30 ticks for example), they will sound inconsistent when played or exported (mixdown) with long ASIO buffers.

This doesn’t happen with other instruments I’ve tried, like Prologue for example.