Weird ASIO Spikes


I have asio spikes randomly. I have my template loaded and this also happens even when I haven´t recorded anything (even when I don´t touch anything). And I have no idea why. There is audio crackle when the spikes happen (if something is playing). I was hoping someone here could help me figure out what else could cause this?

If I run latencymon while Cubase is on, the highest latency is from the ohci1394.sys driver (around 0.42 ms). If I run latencymon when cubase is off the same driver has around 0.003 ms. This is normal I guess? I have to use the old legacy 1394 driver for my fireface 400 soundcard. Otherwise windows 10 will have a BSOD and reboot.
The “Current measured interupt to process latency (μs)” is around 11 μs when I run it with no programs open in windows. So there is nothing worng according to latencymon.
When the spikes happens I can´t see anything happening in latencymon. So I have no idea how to find the problem and solve this.

In windows Performance options/advanced I have it set to “Background services” instead of “Programs”. Is that correct? Also I´ve changed the virtual memory to 4096 (both initial size and maximum size accordning to a guide) instead of letting windows handle that. (EDIT----- I tried switching to Programs, and I tried letting windows deal with the virtual ram settings. Still the same problem)

My Buffer Size is very hig, 512. (EDIT----Am trying 128 right now.)

In the project I´m using Waves SSL EQ 4000, L3-LL Multimaximizer, C6, scheps 73, Altiverb 7.2.9, Valhalla Room, Fabfilter Pro Q 2, Cubase MixerDelay and maybe some more that I might miss (not by the music PC). I´m using a lot of instruments from Orchestral Tools. About 200 instrument tracks are loaded, and another maybe 250 instruments track that´s disabled. The template uses 33gb of ram. In kontakt the instrument preload buffer size is set to 42 kB.

The overall ASIO load is low, around 17% when the template is loaded and not playing. And it increases a little bit when playing (around 17-25%) (I´m using 29 instr at the same time in the example I have in my template right now).

In Cubase I´ve tried both with and without asio guard (including disabling all vst plugins that I use). There is no difference (except that the average load increases, just like it should).

In the BIOS settings this is disabled:
CPU Ebhanced Halt (C1E)
C3 State
C6/C7 State
CPU Thermal Monitor
CPU EIST Function

I have not overclocked anything.

In Windows I have disabled the “High definition Audio Controller” under System devies. Bluetooth and wireless network adapters are disabled as well.

Please help!

Windows 10, Cubase 9.0.10, Kontakt 5.6.5, Gigabyte GA-X99-UD5, Intel Core i7 5930K 3,5GHz, 64Gb memory, Sonnet Allegro FW800-E, RME FireFace 400, Asus GeForce GTX 960, Samsung 850 EVO 4x 500Gb, 2x 250Gb, 1x 120Gb.

Thanks in advance!

Have you tried activating the Steinberg audio power scheme in device set up?

No, but isn´t that the same as tweaking the windows 10 power options in the control panel? I have it set to high performance and nothing is set to be suspended. Will cubase setting change something else? I will try it, thanks.


I checked the power options and nothing has changed from my previous settings there after activating the steinberg audio power scheme.

Oh…so much for the Steinberg power scheme then :unamused: :unamused:

After a day without using Altiverb 7, the problem is gone. Same template, just disabled altiverb 7. This is the second time I have problems with the same plugin :confused: (last time altiverb caused Cubase to crash when selecting multiple instrument tracks)… Have to report it to audio ease. But feels good anyway that my PC is fine =)

Does altiverb have any settings for latency or cpu load? If yes try these. I use the old wizooverb sometimes and that one is very spiky at the wrong setting. If I remember correctly, zero latency mode has a higher cpu load but no spikes.

Interesting, I don´t know actually. Will look it up. I´ll tell when I know. Thanks