Weird audio drop problem


First for starters, the way I’m using wavelab for mastering.
I import all the tracks and transform each one in a submontage, two times.

The first montage is digital preprocessing with external FX (analog loop) as last insert.
The second one “catches” the render of that first montage and get all the post processing + digital limiting as last insert.
The mother montage “catches” all the limited and finished masters, and in that montage I edit clips, markers, fades, etc.

Lately, I changed from wavelab 9.5 to 10, also computer and soundcard at the same time, so difficult to identifies from where comes my problem.

The problem is, that sometimes, in the rendered wav of a submontage, there is an audio drop, but a curious one. the files gets longer of one buffer and get padded at that point with (since I’m at 256 buffer size ATM) 256 samples at -oo dBFS. See first picture attached, I highlighted the zone and you can see in the bottom right that it’s exactly my buffer size :

So if I cut that part, you see that the audio lines up perfectly :

Is this a bug ?
Usually when there is a drop, you loose x number of buffers, but it doesn’t seem to do that here. What’s time consuming about that is that wavelab doesn’t inform anything about that, and it has been quite some time that I triple check every file that gets out.

Any ideas ?

What are your audio device latency settings? (try higher)

It’s a Motu 8D used in AES with my Crookwood converters.
Latency inside the Motu is 256 samples.

In Wavelab I have 75 ms asio guard.

I tried with bigger latency (512 and 1024), but it’s the same. I don’t have DPC spikes either.

Sometimes out of 10 tracks, there is one with a zero padded buffer, sometimes 3 or 4 out of 10.

What computer?
Using WaveLab 10.0.40 I assume?

Yes Wavelab 10.0.40
Computer is a Razer Blade 15 mid 2019.

Where are your external FX used in your WaveLab workflow? (montage? Master Section?)

They are in the master part of the montage, in the inspector, not in the master section.

Try in the Master Section.

Thanks Philippe,

I’ll try for some time and get back to you if it worked or not.

Hello Philippe,

I didn’t get the bug at all since rendering from the master section instead of “from the inspector”.
I guess it is a bug on the inspector side then !