Weird Delay on my recordings

I’m using a Zoom R20 to record bass into Cubase and something really odd has started happening. When I record anything it has a (quite long) delay added to it as it records. I’m not talking output delay, I’m direct monitoring it so when I record it all sounds fine. However I can actually see the waveform going down into the editor some time (quite a lot, almost half a beat) after I have played. When I play it back it’s out of time with all the other tracks. As far as I can tell it’s not a hardware issue, it only happens in Cubase and on top of this it worked fine for months up until yesterday!
Anybody got any idea what is going on? I haven’t updated anything, I can’t see the reason for this!

You can see how far it is out on this…

Hi and welcome to the forum,

Unfortunately the Zoom driver is quite poor. Could you try to use ASIO4ALL instead?

I already was using that, it won’t even find the R20 driver.
I don’t really understand why it worked for 4 months and then stopped working yesterday!


Any (hidden) Windows update?

I’m not really sure, didn’t update when I shut it down and on starting up the next day it just went strange…