Weird glitch with filter - solved.


My whole filter section in the zone section has stopped working while i was working on this preset…

What a weird glitch. I dunno how to get the filter section to work again… I closed halion, reopened etc…

I have a duplicate patch that is very similar except for some trigger pads and the QC’s next to the trigger pads are not assigned to the filter section but to something else. - and the filter section still works on that “semi-dupe” preset…

Does anybody know whats going on?



The quick controls and filters semi work with some filter types. :
From BIT RED downwards, the filter semi works.
Classic, tube and hard do not work at all.

Semi works? What do you mean?

Well, the quick controls affect the sound in the filter section that they should be controlling, but the gui does not reflect what is happening.

  • also, moving things on the gui do not reflect movements on the QC’s of halion.

What do you mean,: do not work at all? :
Well, the gui does not respond, the QCs do not respond, the sound does not get affected…

Off topic and a side note: why does the filter shape go from D,C,B,A from top down… Shouldnt it be A,B,C,D?

Hi gcc,

i guess you have a relative QC assigned to your filter type.
Go to QC setting on the layer editor and switch it to ‘absolute’. I guess this is what you want on a filter type.



Without the program, it’s hard to follow your description. I can only speculate what is happening.

Could it be that you assigned a QC to the filter type? If so, the filter might be set to Off through the QC. Parameters with a QC assigned have a value tool tip when you hover the mouse over the control. This might help you to investigate this.

There are two types of QC assignments: Relative and Absolute. Relative QC assignments apply an offset to the value of the control. Therefore, the UI cannot follow. Absolute QC assignment directly modify the value of the control. That’s why the UI follows in this mode.

The filter shapes are listed in descending order so they align with the position of the xy control of the filter section.

I hope, this helps you to sort things out.

Thank you so much , dear Mahoni and Matthias=)

SOLUTION: Quick controls were set to "relative"

Rock on!